This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 834349 - Fails to preserve WPA protocol preference when connections are edited
Fails to preserve WPA protocol preference when connections are edited
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.3
All Linux
urgent Severity high
: rc
: 6.3
Assigned To: Dan Williams
Desktop QE
: ZStream
Depends On:
Blocks: 782183 837401 840699 864830
  Show dependency treegraph
 
Reported: 2012-06-21 11:30 EDT by Dan Williams
Modified: 2013-02-21 05:34 EST (History)
7 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-37.el6
Doc Type: Bug Fix
Doc Text:
When a connection was locked to a specific WPA protocol version (either v1 or v2/RSN) via either the GConf system or settings in the /etc/sysconfig/network-scripts/ configuration files, the NetworkManager UI overwrote that preference when the connection was edited and saved. This bug has been fixed and such WPA preferences are now preserved in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:34:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Preserve WPA protocols and ciphers when editing connections (7.61 KB, patch)
2012-06-21 14:25 EDT, Dan Williams
no flags Details | Diff
Preserve WPA protocols and ciphers when editing connections (8.50 KB, patch)
2012-08-20 12:12 EDT, Dan Williams
no flags Details | Diff

  None (edit)
Description Dan Williams 2012-06-21 11:30:25 EDT
When a connection is locked to a specific WPA protocol (either v1 or v2/RSN) via either GConf or WPA_ALLOW_WPA/WPA_ALLOW_WPA2 in /etc/sysconfig/network-scripts, the UI overwrites that preference when the connection is edited and saved.
Comment 2 Dan Williams 2012-06-21 14:25:25 EDT
Created attachment 593537 [details]
Preserve WPA protocols and ciphers when editing connections
Comment 3 John Walicki 2012-06-21 23:28:11 EDT
The internal IBM Linux deployment team is interested in this patch.
Comment 4 RHEL Product and Program Management 2012-07-16 18:50:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 6 Dan Williams 2012-08-20 12:12:54 EDT
Created attachment 605730 [details]
Preserve WPA protocols and ciphers when editing connections

Updated patch fixes a crash when editing WPA-PSK connections.
Comment 11 errata-xmlrpc 2013-02-21 05:34:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0429.html

Note You need to log in before you can comment on or make changes to this bug.