Bug 834393 - Subscription Manager GUI : In first boot, after registering with valid credentials on clicking back button it does not return to Subscription Registration page
Subscription Manager GUI : In first boot, after registering with valid creden...
Status: CLOSED DUPLICATE of bug 853035
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-21 14:29 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 17:09:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Clicking on back button after registering takes you to this page (98.09 KB, image/png)
2012-06-21 14:30 EDT, Sharath Dwaral
no flags Details
error1 screenshot (67.02 KB, image/png)
2012-09-06 07:02 EDT, spandey
no flags Details
error 2 screenshot (73.78 KB, image/png)
2012-09-06 07:03 EDT, spandey
no flags Details

  None (edit)
Description Sharath Dwaral 2012-06-21 14:29:27 EDT
Description of problem:
In first boot, after registering with valid credentials on clicking back button it does not return to Subscription Registration page

Version-Release number of selected component (if applicable):

RHEL 5.9

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5

How reproducible:
Always

Steps to Reproduce:
1. Unregister Subscription Manager  
   # subscription-manager unregister
2. Remove systemid file from /etc/sysconfig/rhn
3. RUN_FIRSTBOOT=YES in /etc/sysconfig/firstboot
4. Make sure only 69.pem is present in /etc/pki/product
5. # firstboot
6. Goto Subscription Registration page, enter valid credentials
7. Click Back button

Actual results:
Clicking on "Back button" brings it back to "subscription registration progress bar screen"

Expected results:
Should take you to Subscription Registration page

Additional info:
Comment 1 Sharath Dwaral 2012-06-21 14:30:06 EDT
Created attachment 593541 [details]
Clicking on back button after registering takes you to this page
Comment 2 RHEL Product and Program Management 2012-06-21 14:47:39 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Bryan Kearney 2012-07-03 15:51:08 EDT
still present in 1.0.8
Comment 4 Bryan Kearney 2012-08-13 09:32:58 EDT
Tested with 1.0.13 test version, and it is not there. PLease re-verity with 1.0.14 or later.
Comment 6 spandey 2012-08-27 03:56:02 EDT
Verified using following rpm with rhel5.9 

subscription-manager-1.0.14-1.git.24.812ba3e.el5
subscription-manager-firstboot-1.0.14-1.git.24.812ba3e.el5
subscription-manager-migration-data-1.11.2.3-1.git.4.8bd27be.el5
subscription-manager-migration-1.0.14-1.git.24.812ba3e.el5
subscription-manager-gui-1.0.14-1.git.24.812ba3e.el5


Not getting progress bar after step 7 

resolving defect as verified
Comment 7 spandey 2012-09-06 07:01:27 EDT
at comment 6 i got confused with verification steps , so marked defect verified , 


its my mistake ,

Retested with following  repro  steps i am able to repro this defect 

launched firstboot
register (onpremises) and subscribe (37060.pem) product with None SLA.
press back button.

Got progress bar.

tested with following rpm 

subscription-manager-migration-1.0.14-1.el5
subscription-manager-1.0.14-1.el5
subscription-manager-gui-1.0.14-1.el5
subscription-manager-firstboot-1.0.14-1.el5


subscription-manager-migration-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
subscription-manager-gui-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
subscription-manager-migration-data-1.11.2.4-1.el5
Comment 8 spandey 2012-09-06 07:02:54 EDT
Created attachment 610256 [details]
error1 screenshot
Comment 9 spandey 2012-09-06 07:03:32 EDT
Created attachment 610257 [details]
error 2 screenshot
Comment 10 Adrian Likins 2012-10-03 17:09:13 EDT
This appears to be working for me now
with slightly newer than 1.0.21-1 
(f01464652441088e48e0f6d2064973be65573c3f to be precise)

I suspect the fix for 853035 also fixed this. 

d3e78e65a154b706ce56a907cbc0313d77c76140

Closing as DUPE

*** This bug has been marked as a duplicate of bug 853035 ***

Note You need to log in before you can comment on or make changes to this bug.