Bug 834412 - [RFE] RPM should set up Apache config, not aeolus-configure
[RFE] RPM should set up Apache config, not aeolus-configure
Status: CLOSED WONTFIX
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: John Eckersberg
Rehana
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 15:12 EDT by Matt Wagner
Modified: 2014-08-17 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 16:53:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Wagner 2012-06-21 15:12:41 EDT
Description of problem:
When I built some Conductor RPMs from source and installed them, they laid down a new /etc/httpd/aeolus-conductor.conf file. It seems to be HTTP (*:80) only.

Apparently, aeolus-configure sets up an HTTPS Apache file, and changes the HTTP config to just throw redirects to the HTTPS one.

This setup makes zero sense. Why not just set up Apache correctly in the RPM, versus laying down a broken configuration and then requiring a script to be run to make it work?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Aeolus RPMs, do not run aeolus-configure
2. Restart Conductor and Apache
3. Visit https://localhost/conductor
  
Actual results:
404

Expected results:
200 (or 302, or even a 304)


Additional info:

Note You need to log in before you can comment on or make changes to this bug.