Bug 834430 - LightDM takes very long to start and login
LightDM takes very long to start and login
Status: CLOSED DUPLICATE of bug 834427
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 834427
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 16:44 EDT by Heiko Adams
Modified: 2012-06-22 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 12:47:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lightdm.log (3.62 KB, text/x-log)
2012-06-21 16:44 EDT, Heiko Adams
no flags Details
log from gtk-greeter (2.95 KB, text/x-log)
2012-06-21 16:44 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2012-06-21 16:44:21 EDT
Created attachment 593593 [details]
lightdm.log

Description of problem:
LightDM currently takes at least extremely long to start. After plymouth finished the screen stays black for several seconds until lightdm greeter is visible, Loging into my desktop takes also several seconds from pressing "login" button until the desktop environment is starting.

Version-Release number of selected component (if applicable):
lightdm-gobject-1.2.2-15.fc17.x86_64
lightdm-1.2.2-15.fc17.x86_64
lightdm-gtk-1.1.6-3.fc17.x86_64

How reproducible:
allways

Steps to Reproduce:
1. install lightdm
2. reboot
3.
  
Actual results:
After plymouth has finished the screen stays black for several seconds.

Expected results:
LightDM should be available imidiately after plymouth finishes, like LXDM does.

Additional info:
Comment 1 Heiko Adams 2012-06-21 16:44:58 EDT
Created attachment 593594 [details]
log from gtk-greeter
Comment 2 Christoph Wickert 2012-06-21 19:23:38 EDT
Is ConsoleKit-x11 installed?
Comment 3 Gregor Tätzner 2012-06-22 04:23:20 EDT
I'm tempted to mark this as a duplicate of 834427. @Heiko Can you have a look at your selinux log and try the suggested workaround?

At least on my system it doesn't make a difference if consolekit-x11 is installed or not.
Comment 4 Rex Dieter 2012-06-22 09:25:24 EDT
it's likely selinux-policy getting in the way, see bug #834427 

(a quick-n-dirty test would be to temporarily set selinux to permissive, and reboot)
Comment 5 Heiko Adams 2012-06-22 12:26:12 EDT
Yes, I can confirm that it's selinux what makes this trouble
Comment 6 Gregor Tätzner 2012-06-22 12:47:23 EDT

*** This bug has been marked as a duplicate of bug 834427 ***

Note You need to log in before you can comment on or make changes to this bug.