Bug 834443 - Can't power on VMs after upgrade from RHEL 6.2 to RHEL 6.3
Can't power on VMs after upgrade from RHEL 6.2 to RHEL 6.3
Status: CLOSED DUPLICATE of bug 790436
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 17:42 EDT by Swapna Krishnan
Modified: 2012-07-24 15:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 15:05:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified guest's xml file (2.57 KB, text/plain)
2012-07-02 22:48 EDT, Geyang Kong
no flags Details
Original guest's xml file (2.37 KB, text/plain)
2012-07-02 22:49 EDT, Geyang Kong
no flags Details

  None (edit)
Description Swapna Krishnan 2012-06-21 17:42:34 EDT
Description of problem: After upgrade from RHEL 6.2 to RHEL 6.3, I can't power on guests through virt-manager. While trying to do so, I get error message:

Error restoring domain: unsupported configuration: spice TLS port set in XML configuration, but TLS is disabled in qemu.conf

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 44, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 65, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1063, in startup
    self._backend.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 620, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: unsupported configuration: spice TLS port set in XML configuration, but TLS is disabled in qemu.conf

virsh configuration: 
...
    <channel type='spicevmc'>
      <target type='virtio' name='com.redhat.spice.0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    </channel>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='spice' port='5930' tlsPort='5931' autoport='no' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
....

I tried removing the tlsPort parameter and restarted libvirtd. I tried to power on guest but it still gave same error message.

Version-Release number of selected component (if applicable):
libvirt-0.9.10-21.el6_3.1.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virt-manager-0.9.0-14.el6.x86_64


How reproducible:
100%


Steps to Reproduce:
1. Upgrade from RHEL 6.2 to RHEL 6.3 using yum
2. Start up virt-manager after reboot
3.Power on guests which existed in RHEL 6.2
4. Guests refuse to power on.
  
Actual results:
Guests do not power on

Expected results:
Guests should power on

Additional info:
Comment 2 Swapna Krishnan 2012-06-25 14:09:37 EDT
I tried modifying /etc/libvirt/qemu.conf by making spice_tls = 0 and removed tlsPort from the domain xml. Then restarted libvirtd and tried to power on the guest. It still gives same error message.
Comment 3 Geyang Kong 2012-06-26 23:43:35 EDT
I have retried this bug with following steps, but I cannot reproduce it. Maybe I missed something, please give me some advice if possible.
1. Install rhel6u2 on host.
2. Install a spice guest, make sure it has following contents in xml.
<graphics type='spice' port='5930' tlsPort='5931' autoport='no' listen='0.0.0.0'>
<listen type='address' address='0.0.0.0'/>
</graphics>
3. Make a rhel6u3 RC4 repo, then execut #yum update
4. Reboot the host.
5. #virsh start $guest(guest cannot be started and there is the same error as bug)
5. Edit /etc/libvirt/qemu.conf, set #spice_tls=1 as spice_tls=0
6. Virsh edit the guest, delete tlsPort='5931' and save it.
7. #service libvirtd restart
8. #virsh start $guest.

Actual Result:
1. After step 8, guest can be started normally.
Comment 4 Swapna Krishnan 2012-06-27 08:29:24 EDT
(In reply to comment #3)
> I have retried this bug with following steps, but I cannot reproduce it.
> Maybe I missed something, please give me some advice if possible.
> 1. Install rhel6u2 on host.
> 2. Install a spice guest, make sure it has following contents in xml.
> <graphics type='spice' port='5930' tlsPort='5931' autoport='no'
> listen='0.0.0.0'>
> <listen type='address' address='0.0.0.0'/>
> </graphics>
> 3. Make a rhel6u3 RC4 repo, then execut #yum update
> 4. Reboot the host.
> 5. #virsh start $guest(guest cannot be started and there is the same error
> as bug)
> 5. Edit /etc/libvirt/qemu.conf, set #spice_tls=1 as spice_tls=0
> 6. Virsh edit the guest, delete tlsPort='5931' and save it.
> 7. #service libvirtd restart
> 8. #virsh start $guest.
> 
> Actual Result:
> 1. After step 8, guest can be started normally.

The same steps don't work for me. 

Could you please mention the version nos of libvirt, qemu-kvm and virt-manager to make sure they are the same as on my machine?
Comment 5 Geyang Kong 2012-06-28 01:03:29 EDT
Looks they are same as yours, they are included by OS build RHEL6.3-20120613.2 x86_64. I didn't change them, and kernel version is 2.6.32-279.el6.x86_64.
Comment 6 Swapna Krishnan 2012-07-02 13:54:45 EDT
(In reply to comment #5)
> Looks they are same as yours, they are included by OS build
> RHEL6.3-20120613.2 x86_64. I didn't change them, and kernel version is
> 2.6.32-279.el6.x86_64.

I updated another one of my machines to RHEL 6.3 from RHEL 6.2 and hit the same issue for all the VMs there. I have now been able to reproduce this on 2 of my machines.

Could you please give me the entire domain xml of your guest? I would like to compare with my guest.
Comment 7 Swapna Krishnan 2012-07-02 15:21:55 EDT
I tried cloning my old VMs and removing just the tlsPort from the xml and was able to power them on. It's only the old VMs which already existed when the upgrade was made which is still giving issues.

Thanks,
- Swapna
Comment 8 Geyang Kong 2012-07-02 22:48:24 EDT
Created attachment 595862 [details]
Modified guest's xml file
Comment 9 Geyang Kong 2012-07-02 22:49:05 EDT
Created attachment 595863 [details]
Original guest's xml file
Comment 10 Geyang Kong 2012-07-02 22:50:34 EDT
I have retried again, still cannot reproduce this bug. And have attached guest's xml file. One is original from 6u2, another one is modified file, from 6u3
Comment 11 Dave Allan 2012-07-24 15:05:19 EDT
This error message explains what's happening:

libvirtError: unsupported configuration: spice TLS port set in XML configuration, but TLS is disabled in qemu.conf

You've requested a secure connection in the guest XML, but the host isn't capable of honoring it.  Rather than silently let you boot insecurely, libvirt now rejects this scenario with this error message.

*** This bug has been marked as a duplicate of bug 790436 ***

Note You need to log in before you can comment on or make changes to this bug.