Bug 834449 - htons() gives warning if compiled with gcc -Wconversion [due to generic byteswap, non-x86/x86_64 platforms]
Summary: htons() gives warning if compiled with gcc -Wconversion [due to generic bytes...
Keywords:
Status: CLOSED DUPLICATE of bug 834447
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 17
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jeff Law
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-21 21:57 UTC by Alex Chernyakhovsky
Modified: 2016-11-24 15:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-21 22:02:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Sourceware 12194 None None None Never

Description Alex Chernyakhovsky 2012-06-21 21:57:09 UTC
glibc fixed a bug in 2010 in which htons() would give a conversion warning when compiled with -Wconversion due to the implementation of the byte-swapping functions. Unfortunately, this fix was only for x86/x86_64 platforms. The fix has now been updated to include the generic byteswap functions.

Please apply this patch to the glibc in Fedora.

For reference, please see http://sourceware.org/bugzilla/show_bug.cgi?id=12194

Comment 1 Alex Chernyakhovsky 2012-06-21 22:02:51 UTC
Sorry, RHBZ experienced a proxy error and submitted this bug report twice.

*** This bug has been marked as a duplicate of bug 834447 ***


Note You need to log in before you can comment on or make changes to this bug.