Bug 834452 - schroot man pages are empty
schroot man pages are empty
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: schroot (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Zach Carter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 18:04 EDT by Kel Byers
Modified: 2012-07-24 19:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 19:29:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kel Byers 2012-06-21 18:04:23 EDT
Description of problem:
`man schroot' provides no documentation. Looking at the man pages shipped with schroot-1.4.25-7.fc17.x86_64 shows that all of the files are basically empty:

$ ls -l /usr/share/man/man?/schroot*
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man1/schroot.1.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot.conf.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot-script-config.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot-setup.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man7/schroot-faq.7.gz

Version-Release number of selected component (if applicable):
1.4.25-7.fc17

How reproducible:
always

Steps to Reproduce:
1. install schroot: `yum install schroot-1.4.25-7.fc17.x86_64'
2. lookup one of the man pages: `man schroot'
  
Actual results:
$ man schroot
 Manual page schroot(1) line ?/? (END) (press h for help or q to quit)

Expected results:

Output of schroot documentation:
SCHROOT(1)                              Debian sbuild                             SCHROOT(1)

NAME
       schroot - securely enter a chroot environment

SYNOPSIS
       schroot  [-h|--help | -V|--version  | -l|--list | -i|--info  | --config | --location
       | --automatic-session  | -b|--begin-session | --recover-session  | -r|--run-session |
       -e|--end-session]   [-f|--force]  [-n  session-name|--session-name=session-name]  [-d
       directory|--directory=directory]  [-u  user|--user=user]  [-p|--preserve-environment]
       [-q|--quiet  |  -v|--verbose]  [-c  chroot|--chroot=chroot  | --all | --all-chroots |
       --all-source-chroots | --all-sessions] [--] [COMMAND [ ARG1 [ ARG2 [ ARGn]]]]

...

Additional info:
Comment 1 Peter Trenholme 2012-07-12 18:01:01 EDT
On my F17 system, I find that the man page for dchroot is also missing.

Note that the following shows that the files, while they exist, have a zero byte
expanded size. This also shows that the problem is restricted to schroot and dchroot.

$ find /usr/share/man/ -type f -exec gunzip -lv '{}' ';' | grep '[[:space:]]0[[:space:]]'
defla 00000000 May 25 10:25                  20                   0   0.0% /usr/share/man/man7/schroot-faq.7
defla 00000000 May 25 10:25                  20                   0   0.0% /usr/share/man/man5/schroot-setup.5
defla 00000000 May 25 10:25                  20                   0   0.0% /usr/share/man/man5/schroot.conf.5
defla 00000000 May 25 10:25                  20                   0   0.0% /usr/share/man/man5/schroot-script-config.5
defla 00000000 May 25 10:25                  20                   0   0.0% /usr/share/man/man1/dchroot.1
defla 00000000 May 25 10:25                  20                   0   0.0% /usr/share/man/man1/schroot.1
Comment 2 Zach Carter 2012-07-12 18:10:41 EDT
I'm not sure what is going on.   I just reinstalled the package from the updates repo, and the man pages are fine on my system.

The rpm package has non-zero sized files, shown here:

[root@nudj ~]# rpm -q --dump schroot|grep man
/usr/share/man/man1/schroot.1.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot-script-config.5.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot-setup.5.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot.conf.5.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man7/schroot-faq.7.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X

Can either of you check the output of "rpm -V schroot" ?
Comment 3 Kel Byers 2012-07-12 18:34:56 EDT
[kel@fedora17 ~]$ rpm -q schroot
schroot-1.4.25-7.fc17.x86_64
[kel@fedora17 ~]$ rpm -V schroot
[kel@fedora17 ~]$ man schroot | head

[kel@fedora17 ~]$ ls -l /usr/share/man/man?/schroot*
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man1/schroot.1.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot.conf.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot-script-config.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot-setup.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man7/schroot-faq.7.gz
[kel@fedora17 ~]$ rpm -qV schroot
[kel@fedora17 ~]$ echo $?
0
Comment 4 Kel Byers 2012-07-12 18:48:03 EDT
I uninstalled schroot, plus the boost prereqs and then reinstalled schroot from the repo. After reinstalling I see the same output that you got above, and the pages are still empty.


[kel@fedora17 ~]$ rpm -q --dump schroot|grep man
/usr/share/man/man1/schroot.1.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot-script-config.5.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot-setup.5.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot.conf.5.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
/usr/share/man/man7/schroot-faq.7.gz 20 1337966712 f61f27bd17de546264aa58f40f3aafaac7021e0ef69c17f6b1b4cd7664a037ec 0100644 root root 0 1 0 X
[kel@fedora17 ~]$ ls -l /usr/share/man/man?/schroot*
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man1/schroot.1.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot.conf.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot-script-config.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man5/schroot-setup.5.gz
-rw-r--r--. 1 root root 20 May 25 12:25 /usr/share/man/man7/schroot-faq.7.gz
[kel@fedora17 ~]$ man schroot | head

[kel@fedora17 ~]$
Comment 5 Zach Carter 2012-07-12 18:55:35 EDT
Ok, I couldn't reproduce it because I had some leftover files on my machine.   I cleaned them up, and now I have the same problem.

Not sure how to fix it yet, but at least I can reproduce it.
Comment 6 Fedora Update System 2012-07-12 19:48:16 EDT
schroot-1.4.25-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/schroot-1.4.25-9.fc17
Comment 7 Fedora Update System 2012-07-14 17:50:06 EDT
Package schroot-1.4.25-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing schroot-1.4.25-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10613/schroot-1.4.25-9.fc17
then log in and leave karma (feedback).
Comment 8 Kel Byers 2012-07-14 18:22:35 EDT
That does indeed fix the missing man pages. Thanks!


[kel@fedora17 ~]$ rpm -q schroot
schroot-1.4.25-9.fc17.x86_64
[kel@fedora17 ~]$ rpm -q --dump schroot|grep man
/usr/share/man/man1/schroot.1.gz 8889 1342136303 b9a814bd7f8718414168a79f8ffaee1a694af90377007fef1efe025e1411efd2 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot-script-config.5.gz 1887 1342136303 1251fb5f7041a59ec506ff4acc1beefe0121916474cfcd2a2d2b73304d5fbe93 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot-setup.5.gz 3529 1342136303 55bbc184fe88a5453546190b7a34a4fd80f8e16b372ad5e10397bf68e65a1ad2 0100644 root root 0 1 0 X
/usr/share/man/man5/schroot.conf.5.gz 9103 1342136303 879a821735122f3e6b97f298ab2ac59aca50f954e61d0911b17800c003ba91de 0100644 root root 0 1 0 X
/usr/share/man/man7/schroot-faq.7.gz 4990 1342136303 a71303a4c895a55b98a99d2f4aeb7f844681584846038df02d3db83d905bdc62 0100644 root root 0 1 0 X
[kel@fedora17 ~]$ rpm -V schroot
[kel@fedora17 ~]$ ls -l /usr/share/man/man?/schroot*
-rw-r--r--. 1 root root 8889 Jul 12 18:38 /usr/share/man/man1/schroot.1.gz
-rw-r--r--. 1 root root 9103 Jul 12 18:38 /usr/share/man/man5/schroot.conf.5.gz
-rw-r--r--. 1 root root 1887 Jul 12 18:38 /usr/share/man/man5/schroot-script-config.5.gz
-rw-r--r--. 1 root root 3529 Jul 12 18:38 /usr/share/man/man5/schroot-setup.5.gz
-rw-r--r--. 1 root root 4990 Jul 12 18:38 /usr/share/man/man7/schroot-faq.7.gz

[kel@fedora17 ~]$ man schroot | head -1
SCHROOT(1)                       Debian sbuild                      SCHROOT(1)
[kel@fedora17 ~]$ man schroot-script-config | head -1
SCHROOT-SCRIPT-CONFIG(5)         Debian sbuild        SCHROOT-SCRIPT-CONFIG(5)
[kel@fedora17 ~]$ man schroot-setup | head -1
SCHROOT-SETUP(5)                 Debian sbuild                SCHROOT-SETUP(5)
[kel@fedora17 ~]$ man schroot-faq | head -1
./schroot-faq.7.man:126: warning [p 2, 7.7i]: cannot adjust line
SCHROOT-FAQ(7)                   Debian sbuild                  SCHROOT-FAQ(7)
Comment 9 Fedora Update System 2012-07-24 19:29:30 EDT
schroot-1.4.25-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.