Bug 834464 - Stat structure contains entries that are too large for defined data type in 32bit EL5
Stat structure contains entries that are too large for defined data type in 3...
Status: CLOSED DUPLICATE of bug 850352
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
3.3.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: shishir gowda
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 18:56 EDT by Joe Julian
Modified: 2013-12-08 20:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 18:28:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test source to produce the error (294 bytes, text/x-csrc)
2012-06-21 18:56 EDT, Joe Julian
no flags Details

  None (edit)
Description Joe Julian 2012-06-21 18:56:21 EDT
Created attachment 593620 [details]
Test source to produce the error

Description of problem:
I found that cups-pdf was failing to write pdf files to the users home directories that were housed in a gluster volume. After added some proper error checking to the source, I discovered that it was failing with EOVERFLOW. This affects nearly all EL5 packages.

I was able to work around it by defining "-D _FILE_OFFSET_BITS=64" in rebuilding that one file I needed.

This can be tested by compiling the attached:
  gcc -g -O0 -o stat stat.c

Copy that to a gluster volume mounted on 32 bit EL5 and run it. It will return:
  stat: Value too large for defined data type
  stating stat: -1 00000000a006a2b9

Note the 32bit truncation of the inode.

Compiling with:
  gcc -D _FILE_OFFSET_BITS=64 -g -O0 -o stat stat.c

and performing the same test produces
  stating stat: 0 00000000a006a2b9

Notice it's still a truncated inode (actual inode was 9bd28da4a006a2b9).

Since EL5 cannot be rebuilt with _FILE_OFFSET_BITS=64, there should be a solution in the fuse interface.
Comment 1 Amar Tumballi 2012-09-26 02:51:11 EDT
Joe, with recent patchset to solve bug 850352 fix this issues? http://review.gluster.org/3955 is submitted and merged in master.
Comment 2 shishir gowda 2012-10-17 08:21:57 EDT
This seems to be a duplicate of bug 850352.
Please re-open the bug if found otherwise.

*** This bug has been marked as a duplicate of bug 850352 ***

Note You need to log in before you can comment on or make changes to this bug.