Bug 834465 - Memory leak in fuse-bridge
Memory leak in fuse-bridge
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity urgent
: ---
: ---
Assigned To: Raghavendra Bhat
:
Depends On:
Blocks: 895528 921770
  Show dependency treegraph
 
Reported: 2012-06-21 19:07 EDT by Joe Julian
Modified: 2015-12-01 11:45 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 921770 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Valgrind from about an hour of agonizingly slow desktop usage. :D (437.04 KB, text/x-log)
2012-06-21 19:07 EDT, Joe Julian
no flags Details
dump file from instance with 2.8g usage (11.91 MB, text/plain)
2012-06-23 16:23 EDT, Joe Julian
no flags Details

  None (edit)
Description Joe Julian 2012-06-21 19:07:22 EDT
Created attachment 593623 [details]
Valgrind from about an hour of agonizingly slow desktop usage. :D

Description of problem:
Since upgrading to 3.3, my personal desktop machine has been oom killing the client about every 48 hours. Mine is only one of two machines that uses the home directory with an xwindows desktop and the other one logs out every night.

Version-Release number of selected component (if applicable):


How reproducible:
About every 48 hours

Steps to Reproduce:
1. Mount the home volume
2. Leave my desktop logged in
  
Actual results:
oom killer kills glusterfs after it consumes around 6 gig

Expected results:
It shouldn't use anywhere near that much

Attached is some valgrind output. I've never really used it before, so I hope I picked the right options that would be helpful.
Comment 1 Joe Julian 2012-06-23 16:23:41 EDT
Created attachment 593942 [details]
dump file from instance with 2.8g usage
Comment 2 Amar Tumballi 2012-07-03 19:55:39 EDT
Johny, can you look at the valgrind report and come up with the fix? Looks like simple one to crack.
Comment 3 Amar Tumballi 2012-11-20 07:29:16 EST
Joe, sorry about *long* delay about this bug. Want to check if you are seeing similar issues with 3.3.1 (or 3.4.0qa2) releases.

Anyways, will get this particular bug addressed soon.
Comment 4 Amar Tumballi 2012-12-26 00:51:36 EST
reducing the priority (from urgent to high), as this issue is not as severe now with 3.4.0qa6 release.
Comment 5 Amar Tumballi 2013-02-01 01:30:47 EST
not seeing much of the leak in fuse bridge now (mainly with proper fd and lock migration code in place). Also the valgrind didn't help us much on top of the recent master branch code.

Reducing the priority to 'medium' and would be closed after running this with the 3.4.0 beta releases.
Comment 6 Vijay Bellur 2013-02-17 19:55:51 EST
CHANGE: http://review.gluster.org/4523 (Better mechanism to handle memory accounting) merged in master by Anand Avati (avati@redhat.com)
Comment 7 Vijay Bellur 2013-02-17 19:58:14 EST
CHANGE: http://review.gluster.org/4524 (mount.glusterfs: Introduce mem-accounting as an option) merged in master by Anand Avati (avati@redhat.com)
Comment 8 Vijay Bellur 2013-02-17 20:03:54 EST
CHANGE: http://review.gluster.org/4525 (libglusterfs: Fix memory leaks in fd_lk_insert_and_merge) merged in master by Anand Avati (avati@redhat.com)
Comment 9 Vijay Bellur 2013-02-17 23:49:56 EST
CHANGE: http://review.gluster.org/4530 (libglusterfs: Fix memory leaks in fd_lk_insert_and_merge) merged in release-3.3 by Anand Avati (avati@redhat.com)
Comment 10 Vijay Bellur 2013-03-03 09:19:28 EST
CHANGE: http://review.gluster.org/4527 (Better mechanism to handle memory accounting) merged in release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 11 Vijay Bellur 2013-03-03 09:19:47 EST
CHANGE: http://review.gluster.org/4528 (mount.glusterfs: Introduce mem-accounting as an option) merged in release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 12 Vijay Bellur 2013-03-03 09:20:43 EST
CHANGE: http://review.gluster.org/4529 (libglusterfs: Fix memory leaks in fd_lk_insert_and_merge) merged in release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 13 Anand Avati 2013-07-18 21:28:09 EDT
REVIEW: http://review.gluster.org/5343 (glusterfsd: Cleanup memory accounting to honor argp_parse properly) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 14 Anand Avati 2013-07-18 21:35:01 EDT
REVIEW: http://review.gluster.org/5343 (glusterfsd: Cleanup memory accounting to honor argp_parse properly) posted (#2) for review on master by Harshavardhana (harsha@harshavardhana.net)

Note You need to log in before you can comment on or make changes to this bug.