Bug 834483 - upgrading to 3.5.2-3 causes "Select session" button to evaporate and forces Gnome session.
upgrading to 3.5.2-3 causes "Select session" button to evaporate and forces G...
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-06-21 22:11 EDT by Valdis Kletnieks
Modified: 2015-02-17 09:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-02-17 09:18:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2012-06-21 22:11:19 EDT
Description of problem:
Something ate the 'select session' button and forced a Gnome login session.  This of course totally sucks if you have a userid that has a custom non-Gnome login session configured.  Worked around it by dropping back to gdm-3.4.1-1

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Valdis Kletnieks 2012-06-21 22:29:50 EDT
Aha. Further info - apparently some bright bulb decided that a new daemon called 'accountsservice' was going to do that:


For reasons I haven't debugged yet, accounts-daemon didn't get started.

Unfortunately, gdm doesn't bother actually *telling* you that accounts-daemon didn't start up or isn't reachable.  If people are going to add dependencies on other packages that will affect the user's ability to login correctly, it should *TELL THE USER* that said dependency isn't available.
Comment 2 Jens Petersen 2012-09-07 04:04:46 EDT
Are you saying Session selection is available initially and then
disappears or that it never appears?
(It is a while since I ran gdm < 3.5.90)

Session selection disappears fairly consistently for me after
initial login with gdm-3.5.90 and gdm-3.5.91.  Even "killall gdm-binary"
doesn't bring it back... but according to systemctl accounts-daemon is running.
Comment 3 Fedora End Of Life 2013-04-03 13:28:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
Comment 4 Fedora End Of Life 2015-01-09 12:12:40 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-02-17 09:18:21 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.