Bug 834503 - Notification related to package install/remove shouldn't be listed under package groups and vice-versa.
Notification related to package install/remove shouldn't be listed under pack...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
medium Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 02:41 EDT by Sachin Ghai
Modified: 2014-03-18 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
showing pkg notification 'add package complete' notification under 'package groups' (58.63 KB, image/png)
2012-06-22 02:41 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-06-22 02:41:13 EDT
Created attachment 593652 [details]
showing pkg notification 'add package complete' notification under 'package groups'

Description of problem:
I installed few system packages (zsh, zip and xterm) via webUI. And notifications/status generated on UI is'Add package complete'.

Later I switched to 'package groups' via radio button for removing package groups on registered client. I removed 3 package groups  and all are removed with notification 'Remove Package group complete'.

But here when we switch from 'Packages' to 'package groups' all notification related to 'packages shouldn't be visible on UI. And similarly when we switch to packages, the notification related to 'packages groups' shouldn't be there.


Version-Release number of selected component (if applicable):

katello-0.1.317-1.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
1. Register a client via rhsm
2. subscribe to any rhel repo
3. install katello-agent on client, start goferd
4. Install package, package group via webUI on registered client

Actual results:
when we switch from 'Packages' to 'package groups' all notification related to 'packages shouldn't be visible on UI. And similarly when we switch to packages, the notification related to 'packages groups' shouldn't be there.


Expected results:
Notification related to package install/remove shouldn't be listed under package groups and vice-versa.

Additional info:
Comment 1 Brad Buckingham 2012-07-19 11:58:01 EDT
The behavior you see is intentional.  In the current implementation, when the user schedules an action using the content form at the top of the table, 1 or more rows will be added below it to indicate that the action is in progress providing a spinner until the action is completed (success or failure).  We do not currently remove/hide entries on the table when the user switches between packages and package groups because the thought was that the user may want to see all of the actions they just scheduled at the same time.  In addition, it may be a little confusing if we hide packages, yet we still list the system's package profile on the pane.

Once an action is completed, the row remains on the pane, until the user refreshes it.  This is on purpose so that the user can see the status of all actions they just scheduled without leaving the pane or performing additional clicks.

I'm not saying that we can't make changes to the current behavior; however, wanted to provide some context.  There are many possible solutions to improve the page; however, one might be to split the pane in to 2 (i.e. Packages and Package Groups), where the user only sees one or the other.  

Note: the code in the upstream Katello has been modified since the screenshot taken to split that table in to 2.  The first is the content form w/ the add/remove links and the second contains the actions in progress and package profile.
Comment 3 Mike McCune 2013-08-16 14:03:58 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 4 Mike McCune 2014-03-18 13:38:48 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.