Bug 834511 - Disallow system to enter S3 or S4 states if virtio devices present
Disallow system to enter S3 or S4 states if virtio devices present
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Amit Shah
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 03:36 EDT by Amit Shah
Modified: 2013-01-07 23:37 EST (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.18-325.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:37:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2012-06-22 03:36:30 EDT
virtio drivers in the RHEL5 kernel are not capable of saving and restoring state information across system suspend states.

Instead of falsely advertising suspend support, and then failing on restore, disallow suspend of the OS itself.

This means that the OS will refuse to enter S3 (suspend-to-memory) and S4 (suspend-to-disk) states if any virtio devices are found.
Comment 4 RHEL Product and Program Management 2012-06-26 09:32:37 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 8 Qunfang Zhang 2012-07-24 03:50:47 EDT
Setting to Assigned first according to comment 7.
Comment 10 Amit Shah 2012-07-24 12:04:25 EDT
> Verified on kernel-2.6.18-330.el5 (guest kernel),  s4 passed, but there's
> some problem with s3, amit is helping to check it. 
> 
> RHEL5.9-32 & 64: 
> S3: Guest calltrace at the second time doing s3.

Even after S3, guest network remains available.  The display doesn't come back, though.  I'm suspecting it's a cirrus driver problem.  That's a separate bz, and for the purposes of this bz, as long as s3 and s4 states aren't entered, we can leave this as it is.

We could open a new bug for the cirrus behaviour, but I doubt it'll be fixed for RHEL5, especially given that we'll disable bios advertisement of s3/s4 for RHEL5 guests.

Setting to ON_QA again.
Comment 11 Qunfang Zhang 2012-07-24 22:47:48 EDT
Ok, I will set this bug to VERIFIED according to comment 7,comment 9, comment 10. Create bug 842942 to track the call trace issue.
Comment 13 errata-xmlrpc 2013-01-07 23:37:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0006.html

Note You need to log in before you can comment on or make changes to this bug.