Bug 834513 - RFE: print list of channels usable by binary to GSpice-DEBUG upon library initialization
RFE: print list of channels usable by binary to GSpice-DEBUG upon library ini...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: beta
: 6.4
Assigned To: Marc-Andre Lureau
Desktop QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 03:48 EDT by David Jaša
Modified: 2013-11-21 03:24 EST (History)
7 users (show)

See Also:
Fixed In Version: spice-gtk-0.20-1.el6
Doc Type: Enhancement
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 03:24:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-06-22 03:48:36 EDT
Description of problem:
print list of channels usable by binary to GSpice-DEBUG upon library initialization. When the spice-gtk-based client is started with spice debug enabled, one of first lines should say:
GSpice-DEBUG: file.c:# available channels: main, inputs, ...

(channel names are in http://cgit.freedesktop.org/spice/spice-gtk/tree/gtk/spice-channel.c#n1857 )

Version-Release number of selected component (if applicable):
spice-gtk 0.11

How reproducible:


Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2012-07-10 02:04:44 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 22:00:45 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Tom Lavigne 2012-09-07 11:24:41 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 4 Marc-Andre Lureau 2012-10-18 08:19:42 EDT
sent patch to ML
Comment 15 errata-xmlrpc 2013-11-21 03:24:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1577.html

Note You need to log in before you can comment on or make changes to this bug.