Bug 834514 - (NPIV_SAN_PASSTHROUGH_TO_GUEST) NPIV - SAN pass-through to the guest [NEEDINFO]
NPIV - SAN pass-through to the guest
Status: CLOSED DUPLICATE of bug 1349115
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Ademar Reis
FuXiangChun
: Reopened
Depends On: 726797 879895 910170 1059956
Blocks: 1320621 1349115 1349117 806907
  Show dependency treegraph
 
Reported: 2012-06-22 03:54 EDT by Daniele
Modified: 2016-09-14 11:21 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 16:15:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dmoessne: needinfo? (platform-rfe)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 758463 None None None 2016-08-08 03:06 EDT

  None (edit)
Description Daniele 2012-06-22 03:54:31 EDT
1. Proposed title of this feature request
NPIV - SAN pass-through to the guest

2. Who is the customer behind the request?
Account name: IZB Informatik-Zentrum Munchen-Frankfurt a.M. GmbH & Co. KG
Customer segment:
TAM/SRM customer: yes, TAM customer
Strategic Customer yes/no: yes


3. What is the nature and description of the request?
The customer needs the possibility to NPIV pass through to the guest.

4. Why does the customer need this? (List the business requirements here)
"we need the implementation to pass-through SAN to our instances (guests) directly, so e.g.  we'll be able to do a live migration of our guests."

5. How would the customer like to achieve this? (List the functional
requirements here)


6. For each functional requirement listed in question 5, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.
Be able to pass the NPIV through to the guest (and therefore see the virtual HBA?)

7. Is there already an existing RFE upstream or in Red Hat bugzilla?
Apparently not one for this particular request.

8. Does the customer have any specific timeline dependencies?
There is no specific timeline, but the sooner the better.

9. Is the sales team involved in this request and do they have any additional input?


10. List any affected packages or components.
Libvirt? not sure

11. Would the customer be able to assist in testing this functionality if
implemented?
They would be able to help us testing
Comment 3 Dave Allan 2012-07-19 18:20:53 EDT
(In reply to comment #0)
> 3. What is the nature and description of the request?
> The customer needs the possibility to NPIV pass through to the guest.
> 
> 4. Why does the customer need this? (List the business requirements here)
> "we need the implementation to pass-through SAN to our instances (guests)
> directly, so e.g.  we'll be able to do a live migration of our guests."

It is currently possible to live migrate a guest with storage that is accessed through NPIV, although it is currently quite a manual process.  A brief overview of what's involved is at:

https://www.redhat.com/archives/libvirt-users/2011-July/msg00026.html

Would it be sufficient for the customer's needs to associate the vHBA with the guest so that the setup/teardown of the vHBA happened automatically?

> 6. For each functional requirement listed in question 5, specify how Red Hat
> and the customer can test to confirm the requirement is successfully
> implemented.
> Be able to pass the NPIV through to the guest (and therefore see the virtual
> HBA?)

The vHBA cannot be attached to the guest as Linux userspace has no ability to access an HBA directly.  Note that the vHBAs created with NPIV are not PCI devices, and thus cannot be passed through to guests.  This design is in the linux kernel and cannot be worked around by any userspace component.

In short, I think the implementation that the customer has requested is not likely to be feasible, but I hope that we can provide an alternative implementation which fulfils their needs.
Comment 7 Martin Tessun 2016-03-15 10:07:52 EDT
Just to clarify this:

It is not sufficient to pass Devices presented via N_Port Virtualisation to the guest, but to passthorugh the complete vHBA to be able to independently run the VM (adding new FC-Devices, etc.).

This is how, e.g. IBM LPARs are working. VMWare and afaik also HyperV are also able to passthrough a virtualised adapter.

As far as I digged into the issue, we would need qemu support and libvirt support for that, as it is currently only possible to passthrough targets from the NPIV Adapter.
This scenario btw. can be easily solved by direct lun attachment as well, so this is not the key-usecase for NP(I)V.
Comment 9 Martin Tessun 2016-08-08 03:06:57 EDT
There are also some requests for this in the Solution as well.
I attached the Solution to this BZ, so one can read the Comments there as well.
Comment 13 Ademar Reis 2016-08-31 16:15:02 EDT

*** This bug has been marked as a duplicate of bug 1349115 ***

Note You need to log in before you can comment on or make changes to this bug.