Bug 834533 - Search widget under 'user notification' page neither clears the search nor save it as favourite.
Search widget under 'user notification' page neither clears the search nor s...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2012-06-22 05:29 EDT by Sachin Ghai
Modified: 2014-09-18 11:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
clear search and save favourite search doesn't work with the search widget under user notification page. (38.40 KB, image/png)
2012-06-22 05:29 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-06-22 05:29:17 EDT
Created attachment 593678 [details]
clear search and save favourite search doesn't work with the search widget under user notification page.

Description of problem:
Clear search and save favourite search doesn't work with the search widget under user notification page.

Version-Release number of selected component (if applicable):
latest puddle 
katello-0.1.317-1.el6_2.noarch
lucene3-3.4.0-2.el6.noarch
elasticsearch-0.18.4-11.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Go to user notifications page by clicking the count on top right corner
2.
3.
  
Actual results:
clear search and save favourite search doesn't work with the search widget under user notification page.

Expected results:
clear search and save favourite search should work as its working with other tabs.

Additional info:
Comment 1 Tom McKay 2013-07-03 12:47:24 EDT
The problem is that the search widget is not tied to any javascript (it's missing the call to KT.search() like panel uses). The correct fix is to convert it to nutupane rather than try to wedge in the search functionality.
Comment 2 Mike McCune 2014-03-18 13:37:22 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.