This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 834538 - libosinfo-0.1.2-1 is FTBFS on ARMv5tel
libosinfo-0.1.2-1 is FTBFS on ARMv5tel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libosinfo (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-06-22 05:36 EDT by Peter Robinson
Modified: 2012-07-16 06:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 06:55:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-06-22 05:36:26 EDT
One of the tests fails

test-loader.c:36:E:Core:test_basic:0: (after this point) Test timeout expired
FAIL: test-loader

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=922119
Comment 1 Daniel Berrange 2012-06-25 08:25:22 EDT
Our test suite has timeouts enabled

[quote 'info check']
To be certain that a test won't hang indefinitely, all tests are run
with a timeout, the default being 4 seconds.  If the test is not
finished within that time, it is killed and logged as an error.

   The timeout for a specific test case, which may contain multiple unit
tests, can be changed with the `tcase_set_timeout()' function.  The
default timeout used for all test cases can be changed with the
environment variable `CK_DEFAULT_TIMEOUT', but this will not override
an explicitly set timeout.  Another way to change the timeout length is
to use the `CK_TIMEOUT_MULTIPLIER' environment variable, which
multiplies all timeouts, including those set with
`tcase_set_timeout()', with the supplied integer value. All timeout
arguments are in seconds and a timeout of 0 seconds turns off the
timeout functionality.
[/quote]

Given that we know ARM is a pretty slow architecture, I expect we need to just increase the default timeout, to longer than 4 seconds, since some of our tests are quite long even on x86.

You can test whether this fixes arm by editing the RPM spec and changing %check to use

  CK_TIMEOUT_MULTIPLIER=5 make check

Note You need to log in before you can comment on or make changes to this bug.