Bug 834547 - [OSS] app is not started after reboot node.
[OSS] app is not started after reboot node.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Krishna Raman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 07:17 EDT by Johnny Liu
Modified: 2015-05-14 21:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:43:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-06-22 07:17:14 EDT
Description of problem:
Due to libra init script is not migrated into OpenShift Origin, after node on which apps are running is reboot, app is not started up.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.Follow http://www.krishnaraman.net/multi-node-openshift-origin-from-scratch/ to setup multi-node env.
2.Create some app
3.Reboot node that some app is running on
4.Access this app after reboot
  
Actual results:
app is not available.

Expected results:
app should be available.

Additional info:
Comment 1 Krishna Raman 2012-07-20 17:50:36 EDT
https://github.com/openshift/crankcase/pull/248
Comment 2 Peter Ruan 2012-07-24 19:49:12 EDT
verified with rebuilt of origin image.

1. create app in broker
2. reboot node that contains the app (look under /var/lib/stickshift/<app_uuid>
3. ssh into app page or view app's main page after reboot was successful.

Note You need to log in before you can comment on or make changes to this bug.