Bug 834632 - Deployment IP address not displayed until page refresh
Summary: Deployment IP address not displayed until page refresh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 1.0.1
Assignee: Imre Farkas
QA Contact: Rehana
URL:
Whiteboard:
Depends On:
Blocks: 836582
TreeView+ depends on / blocked
 
Reported: 2012-06-22 15:54 UTC by James Laska
Modified: 2016-09-20 05:02 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cloud Engine contained an erroneous URL definition for instances, which disabled automatic updates on Application pages. This update corrects the URL definition and provides automatic updates on Application pages.
Clone Of:
: 836582 (view as bug list)
Environment:
Last Closed: 2012-07-10 07:24:16 UTC


Attachments (Terms of Use)
before-reload.png (100.33 KB, image/png)
2012-06-22 15:54 UTC, James Laska
no flags Details
after-reload.png (109.57 KB, image/png)
2012-06-22 15:54 UTC, James Laska
no flags Details
aeolus-debug-20120622115236.tar.gz (3.00 MB, application/octet-stream)
2012-06-22 15:56 UTC, James Laska
no flags Details
ec2 instance with IP address (248.71 KB, image/png)
2012-06-28 23:28 UTC, Ronelle Landy
no flags Details
rhevm instance with IP address (219.44 KB, image/png)
2012-06-28 23:29 UTC, Ronelle Landy
no flags Details
vsphere instance with IP address (244.96 KB, image/png)
2012-06-28 23:30 UTC, Ronelle Landy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1063 normal SHIPPED_LIVE CloudForms Cloud Engine 1.0.1 bug fix update 2012-07-10 11:18:41 UTC

Description James Laska 2012-06-22 15:54:08 UTC
Created attachment 593782 [details]
before-reload.png

Description of problem:

When deploying an application, the "IP Address" field does not automatically update with the expected IP address (or hostname).  I've tried waiting 5, 10, 20 minutes, but the IP Address field is never populated.  Only after a page refresh, does the IP address appear.

Version-Release number of selected component (if applicable):
 * aeolus-conductor-0.8.31-1.el6cf.src.rpm
 * aeolus-configure-2.5.7-2.el6_2.src.rpm
 * rubygem-aeolus-cli-0.3.3-2.el6_2.src.rpm
 * rubygem-aeolus-image-0.3.0-12.el6.src.rpm

How reproducible:
 * Reproduced using firefox-12 and rhev/vsphere/ec2 deployments

Steps to Reproduce:
1. Install aeolus-all, run aeolus-configure -p mock,ec2,rhevm,vsphere
2. Build and push an image
3. Create application blueprint from image
4. Deploy image
5. Wait 5 minutes ...
  
Actual results:

See screen attached screenshot (before-reload.png)

Expected results:

See attached screenshot (after-reload.png)


Additional info:

Comment 1 James Laska 2012-06-22 15:54:32 UTC
Created attachment 593783 [details]
after-reload.png

Comment 2 James Laska 2012-06-22 15:56:05 UTC
Created attachment 593784 [details]
aeolus-debug-20120622115236.tar.gz

Comment 7 Tzu-Mainn Chen 2012-06-27 17:31:21 UTC
ACK'd and pushed to 1.0.1 branch

Comment 10 Dan Macpherson 2012-06-28 04:18:14 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
aeolus-conductor contained an erroneous URL definition for instances, which disabled automatic updates on Applications pages. This update corrects the URL definition and provides automatic updates on Applications pages.

Comment 11 Dan Macpherson 2012-06-28 05:17:28 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-aeolus-conductor contained an erroneous URL definition for instances, which disabled automatic updates on Applications pages. This update corrects the URL definition and provides automatic updates on Applications pages.+aeolus-conductor contained an erroneous URL definition for instances, which disabled automatic updates on Application pages. This update corrects the URL definition and provides automatic updates on Application pages.

Comment 12 Ronelle Landy 2012-06-28 23:27:51 UTC
Tested launching instances to vsphere, rhevm and ec2. All three deployments updated in the conductor GUI to show a running state and an IP address after 2-5 minutes (depending on server load) without requiring a manual page refresh.

See attached screenshots. (taken on Firefox browser)

rpms tested:

rpm -qa |grep aeolus
aeolus-conductor-daemons-0.8.33-1.el6cf.noarch
aeolus-conductor-0.8.33-1.el6cf.noarch
aeolus-all-0.8.33-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-configure-2.5.10-1.el6cf.noarch
aeolus-conductor-doc-0.8.33-1.el6cf.noarch

Marking this BZ as verified in the latest puddle built on 06/28/2012 with aeolus-conductor version listed above

Comment 13 Ronelle Landy 2012-06-28 23:28:37 UTC
Created attachment 595155 [details]
ec2 instance with IP address

Comment 14 Ronelle Landy 2012-06-28 23:29:09 UTC
Created attachment 595156 [details]
rhevm instance with IP address

Comment 15 Ronelle Landy 2012-06-28 23:30:25 UTC
Created attachment 595157 [details]
vsphere instance with IP address

Comment 18 errata-xmlrpc 2012-07-10 07:24:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html


Note You need to log in before you can comment on or make changes to this bug.