Bug 834647 - Unable to schedule package installs on subscribed systems
Unable to schedule package installs on subscribed systems
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
medium Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 12:24 EDT by James Laska
Modified: 2014-09-18 11:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 08:54:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug-20120622120552.tar.gz (3.64 MB, application/octet-stream)
2012-06-22 12:24 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2012-06-22 12:24:28 EDT
Created attachment 593791 [details]
katello-debug-20120622120552.tar.gz

Description of problem:

Attempting to schedule package installations on subscribed systems fails.  This appears to be a regression of a 1.0 feature.  I've requested cloudforms-1.0.z flag to discuss the impact of this issue.

Version-Release number of selected component (if applicable):
 * candlepin-0.6.5-1.el6_2.src.rpm
 * katello-0.1.317-1.el6_2.src.rpm
 * katello-candlepin-cert-key-pair-1.0-1.src.rpm
 * katello-certs-tools-1.0.7-1.el6_3.src.rpm
 * katello-cli-0.1.111-1.el6_2.src.rpm
 * katello-configure-0.1.110-1.el6_3.src.rpm
 * katello-qpid-broker-key-pair-1.0-1.src.rpm
 * katello-qpid-client-key-pair-1.0-1.src.rpm
 * katello-selinux-0.1.10-1.el6.src.rpm
 * pulp-1.0.4-1.el6.src.rpm
 * python-qpid-0.14-8.el6.src.rpm
 * qpid-cpp-0.14-16.el6.src.rpm

How reproducible:
 * Failed for clients: 5Server and 6Server (i386, x86_64)

Steps to Reproduce:
1. Select Systems -> All
2. Choose a subscribed system, then select "Packages"
3. Enter a package that isn't currently installed (example 'vte'), select "Add"
  
Actual results:

 * See attached screenshot (Add Package Error)

Expected results:

 * Package successfully installed

Additional info:
 * I'm able to install the desired package on the system, just not via katello
 * See attached katello-debug logs
Comment 4 Mike McCune 2013-08-16 14:05:33 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.