Bug 834653 - Replace ppc64 with %{power64} macro in python spec
Replace ppc64 with %{power64} macro in python spec
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
17
ppc64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: f18-ppc64p7
  Show dependency treegraph
 
Reported: 2012-06-22 12:51 EDT by Brent Baude
Modified: 2013-02-07 10:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 10:03:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Baude 2012-06-22 12:51:00 EDT
Description of problem:

RPM (as of 4.9.1.3-6.fc17) now honors a %{power64} macro that leads to additional subarchitectures coming in F18.  For Fedora 17, please update the sendmail spec to facilitate testing of the package. A patch will be provided.

|---- python.spec.orig	2012-05-04 12:55:56.578843180 -0400
+++ python.spec	2012-05-04 12:57:05.238843180 -0400
@@ -47,7 +47,7 @@
 %global with_systemtap 1
 
 # some arches dont have valgrind so we need to disable its support on them
-%ifarch %{ix86} x86_64 ppc ppc64 s390x
+%ifarch %{ix86} x86_64 ppc %{power64} s390x
 %global with_valgrind 1
 %else
 %global with_valgrind 0
@@ -901,7 +901,7 @@
 
 %patch130 -p1
 
-%ifarch ppc ppc64
+%ifarch ppc %{power64}
 %patch131 -p1
 %endif
 
@@ -1056,7 +1056,7 @@
 BuildPython debug \
   python-debug \
   python%{pybasever}-debug \
-%ifarch %{ix86} x86_64 ppc ppc64
+%ifarch %{ix86} x86_64 ppc %{power64}
   "--with-pydebug --with-tsc --with-count-allocs --with-call-profile" \
 %else
   "--with-pydebug --with-count-allocs --with-call-profile" \
@@ -1254,7 +1254,7 @@
 %global _pyconfig32_h pyconfig-32.h
 %global _pyconfig64_h pyconfig-64.h
 
-%ifarch ppc64 s390x x86_64 ia64 alpha sparc64
+%ifarch %{power64} s390x x86_64 ia64 alpha sparc64
 %global _pyconfig_h %{_pyconfig64_h}
 %else
 %global _pyconfig_h %{_pyconfig32_h}
@@ -1327,7 +1327,7 @@
 # Install a tapset for this libpython into tapsetdir, fixing up the path to the
 # library:
 mkdir -p %{buildroot}%{tapsetdir}
-%ifarch ppc64 s390x x86_64 ia64 alpha sparc64
+%ifarch %{power64} s390x x86_64 ia64 alpha sparc64
 %global libpython_stp_optimized libpython%{pybasever}-64.stp
 %global libpython_stp_debug     libpython%{pybasever}-debug-64.stp
 %else
Comment 1 Dave Malcolm 2012-06-22 13:21:14 EDT
[BTW, you wrote "sendmail spec" in comment #0, and in all of the other bugs I see below bug 834619.  The meaning is clear, though]
Comment 2 Dave Malcolm 2012-06-22 13:24:43 EDT
Looks like we need similar changes to python3.spec also.
Comment 3 Brent Baude 2012-06-22 13:27:17 EDT
I sure did; that's what happens when you work Friday's I guess.  The titles are correct so hopefully folks will excuse the mistake.

Do you want me to cut another bug for python3?
Comment 4 Dave Malcolm 2012-06-22 13:52:19 EDT
(In reply to comment #3)
> I sure did; that's what happens when you work Friday's I guess.  
:)

> The titles are correct so hopefully folks will excuse the mistake.
No worries, I was just being overly pedantic, sorry.


> Do you want me to cut another bug for python3?
No need, I've already committed fixes, building them now:

  python:master (for f18)
    http://pkgs.fedoraproject.org/gitweb/?p=python.git;a=commitdiff;h=663654f40ffd9cd7f1c42dd5a27ec7125180ead4
    Building python-2.7.3-9.fc18 for dist-rawhide
    Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4188848

  python:f17
    Cherrypicked for f17 as:
       http://pkgs.fedoraproject.org/gitweb/?p=python.git;a=commitdiff;h=b6f7740eb05c414d1051dd3944649180bd3e0bd9
    Building python-2.7.3-7.1.fc17 for f17-candidate
    Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4188890

  python3:master (for f18)
    http://pkgs.fedoraproject.org/gitweb/?p=python3.git;a=commitdiff;h=cc2383541f5417adcfb8d734f6cdefecfc4f22c0
    Building python3-3.2.3-10.fc18 for dist-rawhide
    Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4188900

  python3:f17
    Cherrypicked for f17 as:
      http://pkgs.fedoraproject.org/gitweb/?p=python3.git;a=commitdiff;h=a2ca9a32d2d410e59f393fd2768e218f06d6277e
    Building python3-3.2.3-7.1.fc17 for f17-candidate
    Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4188904
Comment 5 Brent Baude 2012-06-22 13:57:08 EDT
Cheers Dave!
Comment 6 David Aquilina 2012-06-22 16:50:09 EDT
Kicked off a scratch ppc64p7 build to test - http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=596049
Comment 7 Phil Knirsch 2013-02-07 10:03:13 EST
Verified to be done for Fedora 18, closing out as currentrelease.

Thanks Dave!

Regards, Phil

Note You need to log in before you can comment on or make changes to this bug.