Bug 834683 - libpulse-browse missing
libpulse-browse missing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 15:02 EDT by Matthew Stoltenberg
Modified: 2013-07-31 23:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 23:08:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
re-enable the removed plugin (24.86 KB, patch)
2012-06-22 16:48 EDT, Matthew Stoltenberg
no flags Details | Diff

  None (edit)
Description Matthew Stoltenberg 2012-06-22 15:02:22 EDT
Description of problem:
libpulse-browse is missing in fedora 17.  This means padevchooser cannot be built.

Version-Release number of selected component (if applicable):
1.1

How reproducible:
always

Steps to Reproduce:
1. verify that libpulse-browse.pc and pulse/browser.h are not part of pulseaudio-libs-devel
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Stoltenberg 2012-06-22 16:48:48 EDT
Created attachment 593826 [details]
re-enable the removed plugin

upstream removed working functionality because they didn't like how it worked.  There appears to be now replacement for this functionality.
Comment 2 Matthew Stoltenberg 2012-06-22 19:26:34 EDT
that patch may not be the cleanest thing...  I created a git repo https://github.com/d3matt/padevchooser.git where the necessary pieces were built in to padevchooser.  This might be a better solution to get this app back in to fedora...
Comment 3 Rex Dieter 2013-05-06 19:04:08 EDT
Are you still interested in getting this into fedora?

If so, I could help make it happen (though I'd prefer upstream involvement)...
Comment 4 Fedora End Of Life 2013-07-03 19:58:15 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2013-07-31 23:08:55 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.