Bug 834695 - [Agent RPM] Agent cannot connect to server for no procedure to configure it
[Agent RPM] Agent cannot connect to server for no procedure to configure it
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.0
Unspecified Unspecified
high Severity medium
: ---
: JON 3.1.1
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: 707235 837381 838582
  Show dependency treegraph
 
Reported: 2012-06-22 15:41 EDT by Zhengping Jin
Modified: 2013-09-11 07:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 838582 (view as bug list)
Environment:
Last Closed: 2013-09-11 07:04:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zhengping Jin 2012-06-22 15:41:41 EDT
Description of problem:
the rpm installed agent uses "service jon-agent start" command to startup. but there is no procedure to configure the agent, it cannot connect to the server.

Version-Release number of selected component (if applicable): 3.1.0-el6

How reproducible: 100%


Steps to Reproduce:
1. freshly install the agent through rpm installation
2. start the agent by "service jon-agent start" command
3. wait, and look at the server side.
  
Actual results:
no procedure to configure the agent to connect to a specific server, the agent cannot connect to the server.

Expected results:
A prompt should be shown to configure the agent for the first time running.
After configuring the server's ip address and other parameters, the agent should be able to connect to the server.

Additional info:
Comment 1 Mike Foley 2012-06-25 11:41:25 EDT
discussed with stefan_n and zjin.  this is a solid BZ.  the mechanism for the agent to connect with the appropriate JON server is config file updates.  the question is how to do this through the RPM process.

possibilities:
1) documentation?
2) manual config file updates after the RPM install?

assigning to stefan.  this will require conversations with crouch, asantos, and loleary to define requirements here ... and determine what approach is best or acceptable for customers.
Comment 2 Stefan Negrea 2012-06-26 15:13:27 EDT
The agent can be configured post RPM installation with the help of the configuration file ({agent-folder}/conf/agent-configuration.xml). There are several settings that can be updated to point to the correct server and port.

The process would be:
1) Install RPM
2) Update the configuration file
3) Restart the agent service


However, this might not desirable for cases where users try to provision multiple machines with automated installation scripts. Will need to further identify user needs and usage patterns to derive requirements and a solution.
Comment 3 Mike Foley 2012-07-02 11:08:49 EDT
documentation.

and the jon agent rpm demo by alexksandar bridges the gap on this.



bz triage by asantos, mfoley, zjin, armine, loleary, viet.
Comment 4 Mike Foley 2012-07-02 11:12:46 EDT
service rhqagent config ..... <<<<---this is a development activity that could be added ... stefan ... could you add this?  


bz triage by loleary, asantos, armine, zjin, foley, viet
Comment 5 Stefan Negrea 2012-07-03 18:12:22 EDT
There are two ways to improve the user experience with regards to agent configuration:

1) Update the documentation to clarify all the possible ways available to configure the agent (config files, environment variables, service options)

2) Add an option to the service script to allow the user to configure the agent. To get the typical interactive prompt for the rhq-agent the user would use the command "service jon-agent config" which in turn would call "rhq-agent.sh --setup --nostart"
Comment 6 Stefan Negrea 2012-07-06 11:30:30 EDT
Suggestion 2 cannot be implemented without changes to the agent and the wrapper script. So this suggestion would require changes to JON and a full build of JON in brew. I recommend adding this functionality as part of JON 3.1.1. 

Suggestion 1 should be sufficient because it is related to functionality delivered with the regular agent today. Suggestion 2 is just an improvement over the functionality currently delivered with regular agent installations.
Comment 7 Charles Crouch 2012-07-09 10:23:22 EDT
This bz is for implementing option 2 as part of jon311
Comment 8 Armine Hovsepyan 2012-07-23 08:21:25 EDT
@Stefan, could you please put this bug as ON_QA so that we could mark it as verified (for case 2 as Charles described). Actually it's verified already. service jon-agent config works and makes correct configuration, which leads to correct agent/server cooperation.
Comment 9 John Sanda 2012-08-02 14:52:25 EDT
JON 3.1.1 ER1 build is available. Moving to ON_QA.

https://brewweb.devel.redhat.com/buildinfo?buildID=226942
Comment 10 John Sanda 2012-08-02 16:36:19 EDT
Moving back to ON_DEV. This should not have been moved to ON_QA as incorrectly noted in comment 9.
Comment 11 Armine Hovsepyan 2012-08-17 03:26:37 EDT
verified since comment #8.

Note You need to log in before you can comment on or make changes to this bug.