Bug 834707 - Screen stays black after switching between consoles
Screen stays black after switching between consoles
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 16:33 EDT by Heiko Adams
Modified: 2013-05-16 11:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: lightdm-1.2.2-18.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 11:06:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2012-06-22 16:33:31 EDT
Description of problem:
After switching between the first and second console (CTRL+ALT+1 and CTRL+ALT+2) the screen stays black and nothing happened.

Version-Release number of selected component (if applicable):
lightdm-gobject-1.2.2-15.fc17.x86_64
lightdm-1.2.2-15.fc17.x86_64
lightdm-gtk-1.1.6-3.fc17.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Login into a new session
2. switch to another console
3. switch back to frist console
  
Actual results:
Screen stays black and it seems nothing is happening 

Expected results:
The desktop should come back to the screen

Additional info:
Comment 1 Christoph Wickert 2012-10-03 06:41:07 EDT
Works fine for me.

Heiko, Rex, are you fine with closing this bug, it is definitely fixed in lightdm-1.3.3-2 and lightdm-gtk-1.3.1-1?
Comment 2 Heiko Adams 2012-10-03 06:47:57 EDT
lightdm-1.3 is not available for Fedora 17
Comment 3 Christoph Wickert 2012-10-03 07:57:36 EDT
No, and it probably never will as it brings some changes to the config. I could not reproduce your problem with lightdm-1.2.2-15 and lightdm-gtk-1.1.6 either, so I think it's fair to just close this but NEXTRELEASE. Lets hear what Rex things.
Comment 4 Heiko Adams 2012-10-03 08:14:41 EDT
If you know that lightdm uses VT7 instead of VT1 there is no problem. But if you i.e. press CTRL+ALT+F2 and then switch back to VT1 (CTRL+ALT+F1) the screen stays blank.
Comment 5 Rex Dieter 2012-10-03 09:50:21 EDT
We can close it CURRENTRELEASE as far as I'm concerned.

Sounds more like a misunderstanding which VT is used (if user *assumes VT1, then yes, switching to VT1 won't work).
Comment 6 Heiko Adams 2012-10-03 09:59:18 EDT
Hint: Most users will assume this because AFAIK all other display managers use VT1
Comment 7 Rex Dieter 2012-10-03 10:03:28 EDT
You know how the saying goes, 
http://www.urbandictionary.com/define.php?term=assume

regardless, as Christoph hinted, lightdm was fixed in future version (1.3) to properly run on vt1 by default.

That said, you might be able to achieve the same with 1.2 on f17, edit 
/etc/lightdm/lightdm.conf
to include:
minimum-vt=1
Comment 8 Rex Dieter 2012-10-03 10:10:14 EDT
This build implements the conf change, if minimum-vt conf *is* the culprit here,
http://koji.fedoraproject.org/koji/taskinfo?taskID=4555253
Comment 9 Fedora Update System 2012-10-03 11:20:32 EDT
lightdm-1.2.2-18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lightdm-1.2.2-18.fc17
Comment 10 Fedora Update System 2012-10-03 19:54:16 EDT
Package lightdm-1.2.2-18.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.2.2-18.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15313/lightdm-1.2.2-18.fc17
then log in and leave karma (feedback).
Comment 11 Heiko Adams 2013-01-03 03:55:50 EST
Totaly forgot: works fine :)

Note You need to log in before you can comment on or make changes to this bug.