Bug 834732 - python-six in EPEL 6?
python-six in EPEL 6?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-six (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 834681
  Show dependency treegraph
 
Reported: 2012-06-22 21:28 EDT by Ralph Bean
Modified: 2012-09-27 13:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
a.badger: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Ralph Bean 2012-06-22 21:28:00 EDT
Packages that depend on python-six are meant to be run on top of both python2 and python3.  Since python-six is not in epel6, the python2 portions of six-enabled packages also cannot make it into epel.

I think the way six is packaged can be improved, allowing support for a python2-only packaging of six for epel, thus opening the door to other six-dependant packages.

 * A patch to think about - http://threebean.org/tmp/tmp.oVUevgMZv3.html
 * Raw version of that patch - http://threebean.org/patches/0001-Conditionalized-python3-six-allowing-an-el6-build.patch
 * Successful scratch build on el6-candidate - http://koji.fedoraproject.org/koji/taskinfo?taskID=4189666
Comment 1 Dave Malcolm 2012-06-25 12:18:14 EDT
Thanks; I've committed and pushed this to master (tweaking the rhel conditional slightly).

I'll make a request to get an el6 branch added
Comment 2 Dave Malcolm 2012-06-25 12:19:12 EDT
Package Change Request
======================
Package Name: python-six
New Branches: el6
Owners: dmalcolm
Comment 3 Toshio Ernie Kuratomi 2012-06-25 14:26:55 EDT
SCM Done.
Comment 4 Fedora Update System 2012-09-27 13:51:45 EDT
python-six-1.1.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-six-1.1.0-2.el6

Note You need to log in before you can comment on or make changes to this bug.