Bug 834733 - LVMError: lvdeactivate failed for f11usr: LV vg_f11/f11usr in use: not deactivating
LVMError: lvdeactivate failed for f11usr: LV vg_f11/f11usr in use: not deac...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:2d5cc4fd57d043d0de242314fb2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 21:49 EDT by Joel Rees
Modified: 2013-02-13 03:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 03:47:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-66oisj (854.23 KB, text/plain)
2012-06-22 21:49 EDT, Joel Rees
no flags Details
dmesg of the running system where this happens (48.38 KB, text/plain)
2012-06-23 04:13 EDT, Joel Rees
no flags Details

  None (edit)
Description Joel Rees 2012-06-22 21:49:33 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-7.fc16.i686
product:        Fedora
reason:         LVMError: lvdeactivate failed for f11usr:   LV vg_f11/f11usr in use: not deactivating
time:           Sat Jun 23 01:46:26 2012
version:        16

anaconda-tb-66oisj: Binary file, 874732 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.25 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicelibs/lvm.py", line 400, in lvdeactivate
:    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 2595, in _teardown
:    lvm.lvdeactivate(self.vg.name, self._name)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 761, in teardown
:    self._teardown(recursive=recursive)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1534, in findExistingRootDevices
:    device.teardown()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
:    upgradeany=flags.cmdline.has_key("upgradeany"))
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
:    self.dispatch()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:LVMError: lvdeactivate failed for f11usr:   LV vg_f11/f11usr in use: not deactivating
:
Comment 1 Joel Rees 2012-06-22 21:49:57 EDT
Created attachment 593843 [details]
File: anaconda-tb-66oisj
Comment 2 Joel Rees 2012-06-23 00:47:42 EDT
Comment on attachment 593843 [details]
File: anaconda-tb-66oisj

This bug will probably be marked a duplicate of the bugs of not being able to update a Fedora install that uses separate / and /usr partitions with LVM and/or RAID.

History: I tried "preupgrade-cli 'Fedora 16 (Verne)'", wasted a whole day's worth of bandwidth downloading 3.7G of updates. Rebooted (and booted to Debian so that Debian, which controls Grub2 on this box, could update the file menu). When the pre-upgrade booted, it declared that it could not find the previous system or the downloaded updates.

After trying a number of things with preupgrade, I burned a CD of the netinstall, which has worked quite well for me in the past. The netinstall CD tells me the same thing about not being able to find the previous system.

So, I looked up the lvm tools and got some reminders from the user list and tried, first, just switching to the virtual console at the screen where the system is examining the storage devices, and activating the LVM volumes. No joy.

Then I tried booting to the rescue system, activating the LVM volumes there, and running anaconda:

/usr/bin/python /usr/bin/anaconda --graphical --selinux --lang
ja_JP.UTF-8 --keymap jp106

Still tells me it can't find the old system and only offers to install new.

Then I tried mounting the LVM partitions under /mnt/sysimage/ , including the old /usr , /var , and all. That was what got this exception. Ergo, it died trying to de-activate the LVM partitions.

Ergo, the cursed installer was de-activating the LVM partitions before looking for the old system, QED, could not find the old system to upgrade or all the fine packages I had wasted so much bandwidth downloading.

So, this bug should be called, "Installer can't find the old system to upgrade because it kicks it out the window before it starts looking."

I'll attach a copy of my dmesg shortly, and then I've had enough. If I have to install from scratch, well, I've been needing an excuse to pick Debian up and use it for a while, not to mention openBSD.

Fedora is obviously under the control of enemies to the open source movement now.
Comment 3 Joel Rees 2012-06-23 00:56:34 EDT
The note in the wiki about RAID being problematic should be fixed to say that there are problems with RAID, LVM, and file systems that separate /usr into a separate partition from / , with links to the stupid arguments about how much better everything will work if the binaries are all one big happy family.

(Seriously, who let those renegades from Microsoft into positions where they could do this to the live Fedora main branch code instead of forking the thing and proving the value of their ideas in a private branch?)
Comment 4 Joel Rees 2012-06-23 01:19:20 EDT
Oh, one more note:

In the transition from the character mode screens getting the language and keyboard settings to the graphical mode, I think it's where the install system is going to multiuser mode, I get two error messages:

systemd[1]: Failed to fully start up daemon: No such file or directory

And udevd had a similar-looking problem with filecon that my fingers weren't fast enough to record. 


And the error message when the efforts to upgrade failed to find the packages looked like

error: cannot open Packages database in /mnt/sysimage/var/lib/rpm

in several versions as it tried to look in various places in various formats.
Comment 5 Joel Rees 2012-06-23 02:41:52 EDT
Okay, I couldn't resist taking one last look at preupgrade-cli.

First, switching to a virtual console to look at the logical volumes' state, the installer seems to be cycling through, activating and de-activating them as it searches.

Second, when preupgrade fails, it tells me (in Japanese)

Upgrade root not found.
No root from a previous install can be found.

Which is really odd, because the root partition is on a primary partition.

Which makes it appear that the real blocking artifact is the blasted merge of /usr into / .

Which means that this bug is destined for the "Won't fix." wastebin.

So, if I were to be seriously inclined to upgrade instead of do a new install, I'd have to move all the LVM stuff out of the second base partition and glom that base partition to the first one using gparted, to get a partition big enough to hold my /usr and the root partition. 

Also means that all those not-so-old Dells at the school where I work, which I have been recommending to switch to Fedora when it's time to clean off MSW7, well, I can't recommend them any more because, even though there's enough CPU and RAM, the hard disk is too small. 

The author of this plan sure seems determined to make Fedora irrelevant to anyone but hard core users.
Comment 6 Joel Rees 2012-06-23 04:13:01 EDT
Created attachment 593867 [details]
dmesg of the running system where this happens
Comment 7 Fedora End Of Life 2013-01-16 05:14:10 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Fedora End Of Life 2013-02-13 03:47:24 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.