Bug 834737 - Failed created app due to timeout is not cleared from mongo
Failed created app due to timeout is not cleared from mongo
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 23:33 EDT by Xiaoli Tian
Modified: 2015-05-14 21:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 11:03:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2012-06-22 23:33:11 EDT
Description of problem:
After failed to creating a scaling jbosseap app due to timeout, it's still listed in rhc domain show, note the log below, there's even no response code.

#rhc app create -a scalejbosseap6 -l xtian+test1@redhat.com -p 123456 -s -t jbosseap-6.0
Creating application: scalejbosseap6 in domainxstg1
Problem reported from server. Response code was .
Re-run with -d for more information.
MESSAGES:
Failed to access resource: Request Timeout

# rhc domain show
scalejbosseap6
    Framework: jbosseap-6.0
     Creation: 2012-06-22T23:00:45-04:00
         UUID: 3b173899010b4deaa73e97438f07fc5c
      Git URL: ssh://3b173899010b4deaa73e97438f07fc5c@scalejbosseap6-domainxstg1.stg.rhcloud.com/~/git/scalejbosseap6.git/
   Public URL: http://scalejbosseap6-domainxstg1.stg.rhcloud.com/

 Embedded: 
      haproxy-1.4

# ping scalejbosseap6-domainxstg1.stg.rhcloud.com
ping: unknown host scalejbosseap6-domainxstg1.stg.rhcloud.com

#rhc app create -a jbossapp1 -t jbossas-7 --enable-jenkins -l xtian+stg1@redhat.com 
Creating application: jenkins in domstg2
Now your new domain name is being propagated worldwide (this might take a minute)...
Confirming application 'jenkins' is available:  Success!
jenkins published:  http://jenkins-domstg2.stg.rhcloud.com/
git url:  ssh://7c5ba79c38df4b5fb95c14399ca0edb9@jenkins-domstg2.stg.rhcloud.com/~/git/jenkins.git/
Jenkins created successfully.  Please make note of these credentials:

   User: admin
   Password: Tw_AAyYJfjq_
Note:  You can change your password at: https://jenkins-domstg2.stg.rhcloud.com/me/configure

Creating application: jbossapp1 in domstg2
There was a problem communicating with the server. Response message: execution expired
If you were disconnected it is possible the operation finished without being able to report success.
You can use 'rhc domain show' and 'rhc app status' to learn about the status of your user and application(s).
Cleaning up application

#rhc domain show -l xtian+stg1@redhat.com 
User Info
=========
Namespace: domstg2
  RHLogin: xtian+stg1@redhat.com

Application Info
================
jbossapp1
    Framework: jbossas-7
     Creation: 2012-06-22T23:16:26-04:00
         UUID: ad35b3f2dc5c4eb1b69bb063a37b18a5
      Git URL: ssh://ad35b3f2dc5c4eb1b69bb063a37b18a5@jbossapp1-domstg2.stg.rhcloud.com/~/git/jbossapp1.git/
   Public URL: http://jbossapp1-domstg2.stg.rhcloud.com/

 Embedded: 
      None

jenkins
    Framework: jenkins-1.4
     Creation: 2012-06-22T23:14:42-04:00
         UUID: 7c5ba79c38df4b5fb95c14399ca0edb9
      Git URL: ssh://7c5ba79c38df4b5fb95c14399ca0edb9@jenkins-domstg2.stg.rhcloud.com/~/git/jenkins.git/
   Public URL: http://jenkins-domstg2.stg.rhcloud.com/

 Embedded: 
      None

#ping jbossapp1-domstg2.stg.rhcloud.com
ping: unknown host jbossapp1-domstg2.stg.rhcloud.com


Version-Release number of selected component (if applicable):
Stage-2.0.13

How reproducible:
Always(if you failed creating app due to timeout)

Steps to Reproduce:
 (Not sure if every one will meet time out, if not, try to set timeout to a low value) 
1.Create an app which may consume much time like scaling jbosseap6, set timeout to low
2.Check domain info
3.Access the failed app
  
Actual results:
The app is failed to create, but it still shows in rhc domain show.

Expected results:
It should be cleared if failing to create

Additional info:
Comment 1 Xiaoli Tian 2012-06-22 23:47:25 EDT
But it could be destoryed successfully:
#rhc app destroy -a scalejbosseap6 -l xtian+test1@redhat.com -p 123456
!!!! WARNING !!!! WARNING !!!! WARNING !!!!
You are about to destroy the scalejbosseap6 application.

This is NOT reversible, all remote data for this application will be removed.
Do you want to destroy this application (y/n): y

RESULT:
Successfully destroyed application: scalejbosseap6
Comment 2 Xiaoli Tian 2012-06-23 06:42:08 EDT
Since the app could be destroyed successfully by user ,let me reduce its severity to not be a  blocker.

Feel free to raise it if you think it needs a fix before release.
Comment 3 Dan McPherson 2012-06-25 11:03:26 EDT
This sounds mostly as designed.  At least the part about a timeout leaves the app there.  Now why the app failed to create correctly might be an issue.  Longer term these sorts of timeouts won't happen because we will be backgrounding app create.  But for now if the client times out you can expect the app create will either be a success and the app will be there or a failure and the app can be destroyed by the client.

Note You need to log in before you can comment on or make changes to this bug.