Bug 834768 - SELinux is preventing /usr/bin/gdb from using the 'ptrace' accesses on a process.
SELinux is preventing /usr/bin/gdb from using the 'ptrace' accesses on a proc...
Status: CLOSED DUPLICATE of bug 799584
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4fdaa68dfb212bd580790c99ce1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 08:12 EDT by matteo_tarantino
Modified: 2012-06-25 05:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 05:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matteo_tarantino 2012-06-23 08:12:50 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.3-1.fc17.i686
time:           Sat 23 Jun 2012 02:12:26 PM CEST

description:
:SELinux is preventing /usr/bin/gdb from using the 'ptrace' accesses on a process.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gdb should be allowed ptrace access on processes labeled mozilla_plugin_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gdb /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Objects                 [ process ]
:Source                        gdb
:Source Path                   /usr/bin/gdb
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gdb-7.4.50.20120120-42.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-132.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.3-1.fc17.i686 #1 SMP Mon
:                              Jun 18 20:52:37 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Sat 23 Jun 2012 02:02:47 PM CEST
:Last Seen                     Sat 23 Jun 2012 02:03:31 PM CEST
:Local ID                      f5f5f58c-606c-4389-90a1-a10f6d8c0107
:
:Raw Audit Messages
:type=AVC msg=audit(1340453011.703:112): avc:  denied  { ptrace } for  pid=2307 comm="gdb" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tclass=process
:
:
:type=SYSCALL msg=audit(1340453011.703:112): arch=i386 syscall=ptrace success=no exit=EACCES a0=10 a1=88e a2=0 a3=0 items=0 ppid=2190 pid=2307 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=gdb exe=/usr/bin/gdb subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gdb,mozilla_plugin_t,mozilla_plugin_t,process,ptrace
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-25 05:03:59 EDT

*** This bug has been marked as a duplicate of bug 799584 ***

Note You need to log in before you can comment on or make changes to this bug.