Bug 834780 - ath9k wireless card does not recognize hardware on/off switch
ath9k wireless card does not recognize hardware on/off switch
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 10:43 EDT by Chris Travers
Modified: 2013-01-02 08:19 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 08:19:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Travers 2012-06-23 10:43:29 EDT
Description of problem:

Can't activate atheros card.  Network Manager is grayed out saying hardware switch disabled.  The switch can be on or off, I still get this message.  I will attach more in a comment below from the box with the issue.

System is a Lenovo G560.  lspci info rfkill info etc, forthcoming.

Version-Release number of selected component (if applicable):

linux-3.4.2-1.fc16.x86_64

How reproducible:

Always reproducible.  

Steps to Reproduce:
1.  Boot to Fedora
2.  Try to activate wireless
3.  Wireless is grayed out
  
Actual results:

Wireless is unavailable.  message is "Wireless is disabled by hardware switch"

Expected results:

Expect to be able to connect to wireless as was possible on Fedora 14.

Additional info:

Forthcoming.
Comment 1 Chris Travers 2012-06-23 10:51:07 EDT
lspci -kv 

05:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Lenovo Device 30a1
	Physical Slot: 1
	Flags: bus master, fast devsel, latency 0, IRQ 10
	Memory at d6400000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Kernel driver in use: ath9k
	Kernel modules: ath9k

With hardware switch on:

[root@localhost ~]# rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes

With hardware switch off:
[root@localhost ~]# rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes

rfkill event shows no events when switch is pushed one way or the other.

[root@localhost ~]# uname -a
Linux localhost.localdomain 3.4.2-1.fc16.x86_64 #1 SMP Thu Jun 14 20:17:26 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I tried uninstalling NetworkManager and using wicd to no avail.  This was working before the upgrade from Fedora 14, and now is not (so I am currently tethered to cables :-( )
Comment 2 Justin M. Forbes 2012-12-07 11:08:21 EST
Is this still an issue with 3.6.9 kernels?

Note You need to log in before you can comment on or make changes to this bug.