Bug 834784 - Can't start VIM due to wrong version of libruby
Can't start VIM due to wrong version of libruby
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 11:16 EDT by Chris Travers
Modified: 2012-06-26 04:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 05:33:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Travers 2012-06-23 11:16:01 EDT
Description of problem:

Trying to start vim, get message:

vim: error while loading shared libraries: libruby.so.1.8: cannot open shared object file: No such file or directory


Version-Release number of selected component (if applicable):

vim-7.3.514-2.fc16.x86_64

How reproducible:

Always

Steps to Reproduce:
1. New install/upgrade
2. start vim from console
3. get error
  
Actual results:

error as above

Expected results:

started vim normally

Additional info:

libruby.so.1.9 is found but not 1.8.  I tried creating a symlink but got undefined symbol errors.  It seems there is a mismatch between the version of VIM packaged and the libraries it links against.  This shouldn't be hard to fix, I would think.....
Comment 1 Karsten Hopp 2012-06-25 05:33:27 EDT
You've got a mix of F16 and F17 packages. Please don't use vim from the F16-updates repo if you have F17 installed. 
The vim version you need is either vim-7.3.515-1.fc17 from F17-updates of even newer vim-7.3.556-1.fc17 from f17-updates-testing.
Comment 3 Chris Travers 2012-06-25 08:15:27 EDT
mea culpa.  I have that resolved and most of my other problems went away (aside from the ath9k issue listed on another bug).

Sorry about that.
Comment 4 Karsten Hopp 2012-06-25 08:22:42 EDT
Actually it wasn't your fault at all. This is what I think has happened:

- You had a F16 system fully updated with vim-7.3.515-2.fc16 
- You updated to F17, but
- the latest F17 vim package available atm is vim-7.3.515-1.fc17 and
  yum/rpm rightly assumes that the F17 package is older and refuses to update the package

This mess was caused by the latest vim package being stuck in f17-updates-testing as that would have been 'newer' than vim-7.3.515-2.fc16, I'm sorry about that and will see if I can get it into f17-updates.
Comment 6 Chris Travers 2012-06-26 04:26:54 EDT
Well, I had a difficult upgrade, and I should have checked rpm versions before assuming everything was proper F17 rpms.  I did a clean install and most of the problems I had went away (again except for the wireless which was previously working no longer working but that's a separate report and something I am also following up on the ath9k-devel list).

If I had checked I would have resolved it myself before filing the report.

Note You need to log in before you can comment on or make changes to this bug.