Bug 834793 - [PATCH] Casts required to build fritzing on ARM
[PATCH] Casts required to build fritzing on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fritzing (Show other bugs)
17
arm Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ed Marshall
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-06-23 12:03 EDT by Chris Tyler
Modified: 2012-07-14 17:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-14 17:52:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fedpkg patch to build on ARM (3.85 KB, patch)
2012-06-23 12:03 EDT, Chris Tyler
no flags Details | Diff

  None (edit)
Description Chris Tyler 2012-06-23 12:03:18 EDT
Created attachment 593917 [details]
fedpkg patch to build on ARM

Description of problem:
The current fritzing package fails to build on ARM (both armv5tel and armv7hl).

Version-Release number of selected component (if applicable):
0.7.1b

How reproducible:
Attempt to build on ARM fails due to a type mismatch causing a template failure.

Additional info:
The attached patch (against fedpkg master branch) includes:
- a patch file that adds casts to two C++ source files
- changes to the specfile to incorporate the patch

Upstream has already added casts to one of the two C++ source files in svn, but not to the other one. I've submitted a patch upstream, see http://code.google.com/p/fritzing/issues/detail?id=2062

(One of the reasons for building this for ARM is to include it in the Raspberry Pi Remix).
Comment 1 Chris Tyler 2012-06-23 13:25:35 EDT
Upstream says that current svn HEAD contains ARM fixes (unsure if they have made it into a release, though).
Comment 2 Fedora Update System 2012-07-03 08:40:59 EDT
fritzing-0.7.5b-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fritzing-0.7.5b-1.fc17
Comment 3 Fedora Update System 2012-07-05 19:39:16 EDT
Package fritzing-0.7.5b-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fritzing-0.7.5b-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10290/fritzing-0.7.5b-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-07-14 17:52:45 EDT
fritzing-0.7.5b-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.