Bug 834828 - Misconfiguration for httpd with Python (the Python module doesn't match the current libraries).
Misconfiguration for httpd with Python (the Python module doesn't match the c...
Status: CLOSED DUPLICATE of bug 844676
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 21:54 EDT by Jesse Pollard
Modified: 2012-09-27 03:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 03:09:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Pollard 2012-06-23 21:54:24 EDT
Description of problem:
During server startup, the Python initialization causes the following errors to be recorded:

...
[Sun Jun 17 03:18:11 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Jun 17 03:18:11 2012] [notice] Digest: done
[Sun Jun 17 03:18:12 2012] [error] python_init: Python version mismatch, expected '2.7.2', found '2.7.3'.
[Sun Jun 17 03:18:12 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Sun Jun 17 03:18:12 2012] [error] python_init: Python path being used '/usr/lib64/python27.zip:/usr/lib64/python2.7/:/usr/lib64/python2.7/plat-linux2:/usr/lib64/python2.7/lib-tk:/usr/lib64/python2.7/lib-old:/usr/lib64/python2.7/lib-dynload'.


Version-Release number of selected component (if applicable):
# httpd -V
Server version: Apache/2.2.22 (Unix)
Server built:   Mar  5 2012 10:52:49
Server's Module Magic Number: 20051115:30
Server loaded:  APR 1.4.6, APR-Util 1.3.12
Compiled using: APR 1.4.6, APR-Util 1.3.12
Architecture:   64-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=128
 -D HTTPD_ROOT="/etc/httpd"
 -D SUEXEC_BIN="/usr/sbin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"


How reproducible:
Appears at every start, and every boot.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
/var/log/httpd/error_log contains the following at the point of restart:
[Sat Jun 23 18:38:50 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/ga.js, referer: http://www.wordplays.com/boggle
[Sat Jun 23 18:41:52 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/ga.js, referer: http://www.wordplays.com/boggle
[Sat Jun 23 18:45:01 2012] [notice] caught SIGTERM, shutting down
Attempt to free unreferenced scalar: SV 0x7ff5b1bbb8d0, Perl interpreter: 0x7ff5b1a570c0 during global destruction.
[Sat Jun 23 18:47:55 2012] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Sat Jun 23 18:47:55 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sat Jun 23 18:47:55 2012] [notice] SSL FIPS mode disabled
Attempt to free unreferenced scalar: SV 0x7fb94df828b0, Perl interpreter: 0x7fb94df61e90 during global destruction.
[Sat Jun 23 18:47:59 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 23 18:47:59 2012] [notice] Digest: done
[Sat Jun 23 18:48:00 2012] [error] python_init: Python version mismatch, expected '2.7.2', found '2.7.3'.
[Sat Jun 23 18:48:00 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Sat Jun 23 18:48:00 2012] [error] python_init: Python path being used '/usr/lib64/python27.zip:/usr/lib64/python2.7/:/usr/lib64/python2.7/plat-linux2:/usr/lib64/python2.7/lib-tk:/usr/lib64/python2.7/lib-old:/usr/lib64/python2.7/lib-dynload'.
[Sat Jun 23 18:48:00 2012] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Sat Jun 23 18:48:00 2012] [notice] mod_python: using mutex_directory /tmp
[Sat Jun 23 18:48:02 2012] [notice] SSL FIPS mode disabled


Expected results:


Additional info:

This doesn't (at present at least) cause problems in what I'm doing, which is serving local web pages to local hosts.

It just implies that the current package is miscompiled.
Comment 1 Jan Kaluža 2012-09-27 03:09:31 EDT

*** This bug has been marked as a duplicate of bug 844676 ***

Note You need to log in before you can comment on or make changes to this bug.