Bug 834851 - 3.1 - vdsm [Direct Lun]: cannot run a vm with IDE interface for direct lun with "Bad volume specification" ERROR
3.1 - vdsm [Direct Lun]: cannot run a vm with IDE interface for direct lun wi...
Status: CLOSED DUPLICATE of bug 820486
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Yeela Kaplan
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 05:41 EDT by Dafna Ron
Modified: 2016-02-02 17:39 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 03:24:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (437.53 KB, application/x-gzip)
2012-06-24 05:41 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-24 05:41:51 EDT
Created attachment 593979 [details]
logs

Description of problem:

I created a Direct lun with IDE interface and attached it to a vm. 
the first run of the vm fails with: Bad volume specification

after I attached a second direct lun which was virtio, I was able to run the vm but I can see in the xml that the disk interface was change to virtio. 

Version-Release number of selected component (if applicable):

si6

How reproducible:

100%

Steps to Reproduce:
1. create a direct lun with IDE disk and attach it to a vm
2. run the vm -> run will fail
3. attach a second direct lun with virtio disk - Run the vm 

Actual results:

IDE disk will fail to run. once we add a second virtio disk the vm ran but both disks were run with virtio. 

Expected results:

we should be able to run a direct lun with IDE interface. 

Additional info: logs



Thread-152200::INFO::2012-06-24 12:06:21,642::clientIF::227::vds::(prepareVolumePath) prepared volume path: 
Thread-152200::DEBUG::2012-06-24 12:06:21,643::vm::580::vm.Vm::(_startUnderlyingVm) vmId=`0ffa8e45-f64d-45f4-9df1-6d165c48f8d8`::_ongoingCreations released
Thread-152200::ERROR::2012-06-24 12:06:21,644::vm::604::vm.Vm::(_startUnderlyingVm) vmId=`0ffa8e45-f64d-45f4-9df1-6d165c48f8d8`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 570, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/libvirtvm.py", line 1290, in _run
    self.preparePaths(devices[vm.DISK_DEVICES])
  File "/usr/share/vdsm/vm.py", line 616, in preparePaths
    drive['path'] = self.cif.prepareVolumePath(drive, self.id)
  File "/usr/share/vdsm/clientIF.py", line 190, in prepareVolumePath
    raise vm.VolumeError(drive)
VolumeError: Bad volume specification {'index': '0', 'iface': 'virtio', 'format': 'raw', 'type': 'disk', 'specParams': {}, 'readonly': 'false', 'deviceId': 'b99f37be-f34e-4fc0-8f8e-dc961102ca2e', 'propagateErrors': 'off', 'device': 'disk
', 'shared': 'false', 'GUID': '1Dafna-Direct11340269', 'optional': 'false'}
Thread-152200::DEBUG::2012-06-24 12:06:21,650::vm::920::vm.Vm::(setDownStatus) vmId=`0ffa8e45-f64d-45f4-9df1-6d165c48f8d8`::Changed state to Down: Bad volume specification {'index': '0', 'iface': 'virtio', 'format': 'raw', 'type': 'disk'
, 'specParams': {}, 'readonly': 'false', 'deviceId': 'b99f37be-f34e-4fc0-8f8e-dc961102ca2e', 'propagateErrors': 'off', 'device': 'disk', 'shared': 'false', 'GUID': '1Dafna-Direct11340269', 'optional': 'false'}


second run: 

 </disk>
                <disk device="disk" snapshot="no" type="block">
                        <source dev="/dev/mapper/1Dafna-Direct11340269"/>
                        <target bus="virtio" dev="vda"/>
                        <serial></serial>
                        <driver cache="none" error_policy="stop" io="native" name="qemu" type="raw"/>
                </disk>
                <disk device="disk" snapshot="no" type="block">
                        <source dev="/dev/mapper/1Dafna-Direct31340269"/>
                        <target bus="virtio" dev="vdb"/>
                        <serial></serial>
                        <driver cache="none" error_policy="stop" io="native" name="qemu" type="raw"/>
Comment 1 Eduardo Warszawski 2012-08-09 03:24:26 EDT
Starting a VM with direct LUN functionality was verified.

This is another instance of the /dev/mapper update race with connectStorageServer and the following operation using the new devices.

Can be solved in the engine level.

We are studying host level (vdsm) solutions.

Thread-152196::DEBUG::2012-06-24 12:06:20,750::task::588::TaskManager.Task::(_updateState) Task=`280110d5-443c-49c9-8f73-7b5ca9b72fca`::moving from state init -> state preparing
Thread-152196::INFO::2012-06-24 12:06:20,751::logUtils::37::dispatcher::(wrapper) Run and protect: connectStorageServer(domType=3, spUUID='e62063ce-2ab1-4140-a67b-f8a51c034688', conList=[{'connection': '10.35.64.10', 'iqn': 'Dafna-Direct1', 'portal': '1', 'user': '', 'password': '******', 'id': '97725e8e-2a71-4192-81d5-0d9e4a210ff0', 'port': '3260'}], options=None)
Thread-152196::DEBUG::2012-06-24 12:06:20,752::__init__::1164::Storage.Misc.excCmd::(_log) '/usr/bin/sudo -n /sbin/iscsiadm -m node -T Dafna-Direct1 -I default -p 10.35.64.10:3260 --op=new' (cwd None)
Thread-152196::DEBUG::2012-06-24 12:06:20,793::__init__::1164::Storage.Misc.excCmd::(_log) SUCCESS: <err> = ''; <rc> = 0
Thread-152196::DEBUG::2012-06-24 12:06:20,794::__init__::1164::Storage.Misc.excCmd::(_log) '/usr/bin/sudo -n /sbin/iscsiadm -m node -T Dafna-Direct1 -I default -p 10.35.64.10:3260 -n node.startup -v manual --op=update' (cwd None)
Thread-152196::DEBUG::2012-06-24 12:06:20,848::__init__::1164::Storage.Misc.excCmd::(_log) SUCCESS: <err> = ''; <rc> = 0
Thread-152196::DEBUG::2012-06-24 12:06:20,849::__init__::1164::Storage.Misc.excCmd::(_log) '/usr/bin/sudo -n /sbin/iscsiadm -m node -T Dafna-Direct1 -I default -p 10.35.64.10:3260 -l' (cwd None)

Thread-152196::DEBUG::2012-06-24 12:06:21,509::__init__::1164::Storage.Misc.excCmd::(_log) SUCCESS: <err> = ''; <rc> = 0

Thread-152196::INFO::2012-06-24 12:06:21,527::logUtils::39::dispatcher::(wrapper) Run and protect: connectStorageServer, Return response: {'statuslist': [{'status': 0, 'id': '97725e8e-2a71-4192-81d5-0d9e4a210ff0'}]}

Thread-152199::DEBUG::2012-06-24 12:06:21,588::BindingXMLRPC::864::vds::(wrapper) client [10.35.97.65]::call vmCreate with ({'custom': {'device_117b2567-2788-4a91-8fad-72acce0539a5device_c6ec1298-e2e6-435d-8da0-5a5f392ad5d5device_04373a8

<snip>

Thread-152200::ERROR::2012-06-24 12:06:21,644::vm::604::vm.Vm::(_startUnderlyingVm) vmId=`0ffa8e45-f64d-45f4-9df1-6d165c48f8d8`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 570, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/libvirtvm.py", line 1290, in _run
    self.preparePaths(devices[vm.DISK_DEVICES])
  File "/usr/share/vdsm/vm.py", line 616, in preparePaths
    drive['path'] = self.cif.prepareVolumePath(drive, self.id)
  File "/usr/share/vdsm/clientIF.py", line 190, in prepareVolumePath
    raise vm.VolumeError(drive)
VolumeError: Bad volume specification {'index': '0', 'iface': 'virtio', 'format': 'raw', 'type': 'disk', 'specParams': {}, 'readonly': 'false', 'deviceId': 'b99f37be-f34e-4fc0-8f8e-dc961102ca2e', 'propagateErrors': 'off', 'device': 'disk', 'shared': 'false', 'GUID': '1Dafna-Direct11340269', 'optional': 'false'}

*** This bug has been marked as a duplicate of bug 820486 ***

Note You need to log in before you can comment on or make changes to this bug.