Bug 834862 - Ovirt CLI - Can't create ISCSI storage domain
Ovirt CLI - Can't create ISCSI storage domain
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Ori Liel
Oded Ramraz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 07:32 EDT by Elena
Modified: 2016-02-10 11:37 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 08:37:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena 2012-06-24 07:32:44 EDT
create storagedomain  --host-name 'blue-vdsb.qa.lab.tlv.redhat.com' --name 'ISCSIDataDomainRest' --storage-logical_unit-address '10.35.64.102' --storage-logical_unit-id '3600144f0bdc38d0000004fc756710011' --storage-type 'iscsi' --type 'data' --storage_format 'v2'

error: syntax error "%s", see help on collection based arguments for more details.
Comment 1 Michael Pasternak 2012-06-24 08:33:36 EDT
error: syntax error at "--storage-logical_unit-address", see help on collection based arguments for more details

this bug caused by incorrect parameter representation in RSDL,
storage-logical_unit [1] implemented as collection while RSDL 
reporting it as Type

[1]

    public List<LogicalUnit> getLogicalUnits() {
        if (logicalUnits == null) {
            logicalUnits = new ArrayList<LogicalUnit>();
        }
        return this.logicalUnits;
    }
Comment 2 Michael Pasternak 2012-06-24 08:37:50 EDT
my bad, - (was on old branch), current RSDL impl is correct (see cli help [1]), usage is not, Elena please always review /help/ to determinate correct option format.

[1]
     Overload 1:
     
     * --name: string
     * --host-id|name: string
     * --type: string
     * --storage-type: string
     * --format: boolean
     * --storage-address: string
     * --storage-logical_unit: collection
       {
         logical_unit.address: string
         logical_unit.port: int
         logical_unit.target: string
         logical_unit.username: string
         logical_unit.password: string
         logical_unit.serial: string
         logical_unit.vendor_id: string
         logical_unit.product_id: string
         logical_unit.lun_mapping: int
         logical_unit.portal: string
         logical_unit.paths: int
         logical_unit.id: string
       }

Note You need to log in before you can comment on or make changes to this bug.