Bug 834881 - Updating system (after upgrade F16 -> F17) fails due to unresolved dependencies
Updating system (after upgrade F16 -> F17) fails due to unresolved dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 10:09 EDT by Philip
Modified: 2014-12-12 13:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-12 13:00:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip 2012-06-24 10:09:29 EDT
Description of problem:
=======================

On a system that was recently upgraded from Fedora 16 to Fedora 17, performing a full system update fails. Yum asked me to file a bug report, so here it is.



---



Version-Release number of selected component (if applicable):
=============================================================

Fedora 17



---



How reproducible:
=================

?



---



Steps to Reproduce:
===================

# yum check-update ; yum -y update



...


  
Actual results:
===============

...
Transaction Summary
================================================================================
Install    7 Packages (+5 Dependent packages)
Upgrade  576 Packages

Total download size: 1.4 G
Is this ok [y/N]: y
...
...
...
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Importing GPG key 0x1ACA3465:
 Userid     : "Fedora (17) <fedora@fedoraproject.org>"
 Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
 Package    : fedora-release-17-1.noarch (@fedora)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Is this ok [y/N]: y
Running Transaction Check
ERROR with transaction check vs depsolve:
ruby(abi) = 1.8 is needed by (installed) ace-0.0.7-3.fc12.noarch
ruby(abi) = 1.8 is needed by (installed) ace-apache-0.0.7-3.fc12.noarch
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 6 pre-existing rpmdb problem(s), 'yum check' output follows:
ace-0.0.7-3.fc12.noarch has missing requires of ruby(abi) = ('0', '1.8', None)
ace-apache-0.0.7-3.fc12.noarch has missing requires of ruby(abi) = ('0', '1.8', None)
compiz-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 has missing requires of libboost_serialization-mt.so.1.47.0()(64bit)
compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 has missing requires of libboost_serialization-mt.so.1.47.0()(64bit)
compiz-plugins-main-0.9.5.92-1.fc16.x86_64 has missing requires of libboost_serialization-mt.so.1.47.0()(64bit)
libcompizconfig-0.9.5.92-1.fc16.x86_64 has missing requires of libboost_serialization-mt.so.1.47.0()(64bit)
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-06-24.10-11.FeI63T.yumtx



---



Expected results:
=================

It should work.



---



Additional info:
================

This command "fixes" the issues:

# yum erase ace-0.0.7-3.fc12.noarch compiz-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.x86_64 compiz-plugins-main-0.9.5.92-1.fc16.x86_64 libcompizconfig-0.9.5.92-1.fc16.x86_64
Comment 1 Philip 2012-06-24 14:08:35 EDT
Don't know if this is related, but on an almost identical system:

# yum install vim
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package vim-enhanced.x86_64 2:7.3.515-1.fc17 will be installed
--> Processing Dependency: vim-common = 2:7.3.515-1.fc17 for package: 2:vim-enhanced-7.3.515-1.fc17.x86_64
--> Finished Dependency Resolution
Error: Package: 2:vim-enhanced-7.3.515-1.fc17.x86_64 (updates)
           Requires: vim-common = 2:7.3.515-1.fc17
           Installed: 2:vim-common-7.3.515-2.fc16.x86_64 (@updates/16)
               vim-common = 2:7.3.515-2.fc16
           Available: 2:vim-common-7.3.444-1.fc17.x86_64 (fedora)
               vim-common = 2:7.3.444-1.fc17
           Available: 2:vim-common-7.3.515-1.fc17.x86_64 (updates)
               vim-common = 2:7.3.515-1.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 2 Fedora End Of Life 2013-04-03 12:50:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 3 Philip 2014-12-12 13:00:21 EST
This is old and F17 is obsolete, so I'll close this bug now.

Note You need to log in before you can comment on or make changes to this bug.