Bug 834899 - Unmounting portable media - unable to handle kernel NULL pointer dereference at 0000009c
Unmounting portable media - unable to handle kernel NULL pointer dereference ...
Status: CLOSED DUPLICATE of bug 768534
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 13:58 EDT by Curtis Adkins
Modified: 2012-08-07 11:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 11:16:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Curtis Adkins 2012-06-24 13:58:56 EDT
Description of problem:
Unmounted SansaClip and went to black screen with kernel oops.  

Version-Release number of selected component (if applicable):17 (Beefy Miracle)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Cut from meesages file:

kernel: [189455.633941] BUG: unable to handle kernel NULL pointer dereference at 0000009c
kernel: [189455.634128] IP: [<c092bd6d>] _raw_spin_lock+0xd/0x30
kernel: [189455.634254] *pde = 00000000 
kernel: [189455.634327] Oops: 0002 [#1] SMP 
kernel: [189455.634410] Modules linked in: nfnetlink_queue nfnetlink xt_iprange xt_mark xt_NFQUEUE xfs btrfs libcrc32c zlib_deflate vfat fat bnep bluetooth lockd sunrpc rfkill nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm ppdev parport_pc parport r8169 8139too 8139cp microcode k10temp sp5100_tco snd_page_alloc snd_timer snd soundcore mii i2c_piix4 uinput ata_generic pata_acpi ums_cypress pata_atiixp usb_storage wmi radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
udisksd[1278]: Unmounted /dev/sde1 on behalf of uid 1000
kernel: [189455.635895] 
kernel: [189455.635936] Pid: 1362, comm: gvfsd-trash Not tainted 3.4.3-1.fc17.i686 #1 MICRO-STAR INTERNATIONAL CO.,LTD MS-7596/760GM -E51 (MS-7596)
kernel: [189455.636218] EIP: 0060:[<c092bd6d>] EFLAGS: 00010292 CPU: 1
kernel: [189455.636338] EIP is at _raw_spin_lock+0xd/0x30
kernel: [189455.636435] EAX: 0000009c EBX: c82989d8 ECX: 00000001 EDX: 00000100
kernel: [189455.636569] ESI: 00000000 EDI: f807d380 EBP: f08f1f30 ESP: f08f1f30
kernel: [189455.636704]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
kernel: [189455.636821] CR0: 80050033 CR2: 0000009c CR3: 308b0000 CR4: 000007d0
kernel: [189455.636955] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
kernel: [189455.637089] DR6: ffff0ff0 DR7: 00000400
kernel: [189455.637176] Process gvfsd-trash (pid: 1362, ti=f08f0000 task=f3a4cb00 task.ti=f08f0000)
kernel: [189455.637344] Stack:
kernel: [189455.637390]  f08f1f40 f807a6c7 c82989d8 c8298a70 f08f1f4c f807a766 c82989d8 f08f1f60
kernel: [189455.637601]  c054a721 c82989d8 c8298a24 f0bc3400 f08f1f78 c054a8a1 f65b7780 ef7032d0
kernel: [189455.637811]  f65b7780 c82989d8 f08f1f94 c056b6b7 00000000 ef7032dc f65b7780 f65b79c0
kernel: [189455.638019] Call Trace:
kernel: [189455.638087]  [<f807a6c7>] fat_detach+0x27/0x70 [fat]
kernel: [189455.638203]  [<f807a766>] fat_evict_inode+0x56/0x60 [fat]
kernel: [189455.638325]  [<c054a721>] evict+0x81/0x140
kernel: [189455.638418]  [<c054a8a1>] iput+0xc1/0x190
kernel: [189455.638511]  [<c056b6b7>] fsnotify_destroy_mark+0x117/0x120
kernel: [189455.638635]  [<c056d1a2>] sys_inotify_rm_watch+0x52/0x90
kernel: [189455.638754]  [<c093311f>] sysenter_do_call+0x12/0x28
kernel: [189455.638861] Code: ff ff ff ff 89 e5 ba 01 00 00 00 e8 ee fe ff ff 5d c3 90 90 90 90 90 90 90 90 90 90 90 90 55 89 e5 3e 8d 74 26 00 ba 00 01 00 00 <f0> 66 0f c1 10 0f b6 ce 38 d1 74 10 8d b4 26 00 00 00 00 f3 90 
kernel: [189455.639632] EIP: [<c092bd6d>] _raw_spin_lock+0xd/0x30 SS:ESP 0068:f08f1f30
kernel: [189455.639791] CR2: 000000000000009c
kernel: [189455.674996] ---[ end trace 527506dde0e24dda ]---
Comment 1 Stanislaw Gruszka 2012-07-13 08:54:12 EDT
Which kernel version is that (see uname -r) ? Is this 100% reproducible? If so, does it work on some other kernel version i.e. 3.4 or 3.3 ?
Comment 2 Curtis Adkins 2012-07-13 12:25:33 EDT
I believe this happend while using kernel 3.4.4-1.  At the moment I am runnig kernel 3.4.4-5 and have had no further issues.
Comment 3 Stanislaw Gruszka 2012-08-07 11:16:32 EDT

*** This bug has been marked as a duplicate of bug 768534 ***

Note You need to log in before you can comment on or make changes to this bug.