Bug 834910 - Screen backlight not functioning after kernel update
Screen backlight not functioning after kernel update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
acpi first=3.4 regression-from=3.3
:
: 830292 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 15:52 EDT by Valentin Villenave
Modified: 2012-07-09 04:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-07 17:54:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ACPI dump (134.82 KB, text/plain)
2012-06-25 16:22 EDT, Valentin Villenave
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 43168 None None None 2012-06-25 10:20:59 EDT

  None (edit)
Description Valentin Villenave 2012-06-24 15:52:09 EDT
Description of problem:

When booting recent kernels (>= 3.4.0) my laptop's screen remains black, the backlight shuts down as soon as the initram image is loaded. No plymouth, no login manager, nothing. Hard drive activity is ordinary and SysReq keys and Alt-Ctrl-Del work, so the O.S. is properly launched even though nothing is visibly displayed.

Version-Release number of selected component (if applicable):

Fedora 17, normal update channels.


How reproducible:

Every boot.


Steps to Reproduce:
1. Yum update, install newer kernel.
2. Reboot.
3. Enjoy the void.

Additional info:

Might be related to other issues such as #752727 or #707688. Except that passing acpi_backlight=vendor or any other boot option doesn't help.

Additionally, my laptop is a Sony VAIO VPC CW1S1E whose screen has been known to be partially unsupported by GNU/Linux (EDID number wrongly recognized). That being said, I had (and still have) no problem booting with kernel 3.3.7, and even backlight-adjustment functions work.
Comment 1 Josh Boyer 2012-06-25 10:20:59 EDT
I believe this is a regression in the ACPI layer.  Can you attach the output of acpidump?
Comment 2 Valentin Villenave 2012-06-25 16:22:45 EDT
Created attachment 594274 [details]
ACPI dump

Here goes.
Comment 3 Josh Boyer 2012-06-26 09:58:55 EDT
OK, this does indeed look like the kernel.org bug I linked to.  Your machine's ACPI lacks _DOS.

I'll try to get a fix committed today.
Comment 4 Josh Boyer 2012-06-26 10:49:30 EDT
Please try this scratch build kernel when it completes:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4196863
Comment 5 Valentin Villenave 2012-06-27 03:24:44 EDT
I tested it several times, and it appears to work. Thanks!
Comment 6 Josh Boyer 2012-07-03 10:25:42 EDT
Thanks for testing.  Fixed in Fedora git.
Comment 7 Fedora Update System 2012-07-05 17:55:41 EDT
kernel-3.4.4-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.4.4-5.fc17
Comment 8 Fedora Update System 2012-07-05 19:50:04 EDT
kernel-3.4.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.4-4.fc16
Comment 9 Fedora Update System 2012-07-06 17:23:32 EDT
Package kernel-3.4.4-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.4.4-4.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10319/kernel-3.4.4-4.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-07-07 17:54:15 EDT
kernel-3.4.4-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-07-08 16:51:16 EDT
kernel-3.4.4-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Lukáš Tinkl 2012-07-09 04:49:59 EDT
*** Bug 830292 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.