This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 83492 - Small 'perturbations' on extreme left of the screen on i8100 with 'nv' driver
Small 'perturbations' on extreme left of the screen on i8100 with 'nv' driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-04 16:28 EST by Need Real Name
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 15:04:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
this is file /etc/X11/XF86Config (3.14 KB, text/plain)
2003-02-05 08:46 EST, Need Real Name
no flags Details
this is the file /var/log/XFree86.0.log (29.65 KB, text/plain)
2003-02-05 08:47 EST, Need Real Name
no flags Details
Screenshot of said lines (60.50 KB, image/jpeg)
2003-05-01 14:29 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-02-04 16:28:56 EST
Description of problem:

On a Inspiron i8100 there are constant small perturbations on the extreme
left side of the screen when using the 'nv' driver.
The 'vesa' driver does not have this problem.
(Neither does the 'nv' driver on an i8200 with GeForce4 440 Go and Phoebe2).

This is on an i8100 with GeForce2 Go and Phoebe2 using the 'nv' driver
from XFree86-4.2.99.3-20030118.3
Very irritating.


Version-Release number of selected component (if applicable):

XFree86-4.2.99.3-20030118.3

How reproducible:

Constantly visible


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2003-02-05 02:18:12 EST
Please upgrade to the latest rawhide release of XFree86 first, and if
the problem persists, please attach your X server config file, log file,
and a screenshot of the visual corruption you are having.  Please test
this in several color depths to see if it only occurs at one depth or
at all depths.
Comment 2 Need Real Name 2003-02-05 08:46:12 EST
Created attachment 89863 [details]
this is file /etc/X11/XF86Config
Comment 3 Need Real Name 2003-02-05 08:47:20 EST
Created attachment 89864 [details]
this is the file /var/log/XFree86.0.log
Comment 4 Need Real Name 2003-02-05 09:05:03 EST
I installed the Rawhide XFree86 rpms ( 4.2.99.4-20030129.5 ).
This makes no difference, the problem persists, and at all color depths
(though it is hardly visible at 24 bits).
It does not show up on a screenshot (it resembles the spectrum graph shown
in xmms when playing music, but with very fine, hair width, white lines dancing
up and down with the left border of the screen as a base. Sometimes at the top,
sometimes in the middle and sometimes at the bottom of the screen. Sometimes
disappearing for seconds/minutes and then beginning again)
If relevant, the screensize is 1400x1050.

By the way the Rawhide rpms break 'redhat-config-xfree86' with the message:

  File "/usr/share/redhat-config-xfree86/xconf.py", line 357
    current_card_driver = current_card.getCardData()["DRIVER"]
                      ^
SyntaxError: invalid syntax
Comment 5 Need Real Name 2003-02-05 09:18:54 EST
Slight correction: the problem persists at all 'usefull' color depths (15,16,24
bits). It is NOT visible at 8 bits.
Comment 6 Mike A. Harris 2003-02-07 05:03:17 EST
Ah, I know exactly what you mean.  They're jittery horizontal lines cycling
up and down all over parts of the display.  I get this on Mach64 hardware,
and have some digital pictures.  Please look at the following and tell
me if any of them look like what you see remotely:

ftp://people.redhat.com/mharris/pictures/RageIIC

The current_card_driver bug is a FSD (Frequently Submitted Dupe), and
long since fixed now.  ;o)
Comment 7 Mike A. Harris 2003-02-07 05:05:01 EST
Oh, by the way, if you have a digital camera, can borrow one, or can
get someone to take pictures for you with good lighting and no flash
that are about as clear as mine above, that would also be appreciated.
Please attach them individually to bugzilla if possible.  Thanks.
Comment 8 Need Real Name 2003-02-09 11:28:07 EST
I have looked at your pictures. They are not very clear. I see nothing
in the pictures resembling what I am experiencing. Do you mean the fuzzy white
lines on the right side of the open windows?

What I see are very very thin white lines (on a dark background) or black lines
(on a light background) looking like a rippling 'histogram' or 'spike graph' on
the extreme left of the screen with the screen border as base of the 'spikes'
which are at most 1-2 cm in height.

Matthias Saou, who also experienced this (phoebe-list, jan 8) described this
as "a very small flickering on the left of my screen".

I am sorry, but I have'nt got a digital camera (not even an ordinary one) and
so far I also have not found anybody among my acquaintances who does.
Comment 9 Janne Pikkarainen 2003-03-12 14:41:17 EST
awol: What kind of monitor you have? With my Samsung SyncMaster 171S (it's a 17"
lcd) I get about the same effect if using the default refresh rate (76 Hz, if I
remember it right) RH 8.0 gives me. If I drop the refresh rate to 60 Hz, the
effect disappears. The resolution I use is 1280x1024 and gfx card is Gainward
GeForce 3 TI-500.
Comment 10 Need Real Name 2003-05-01 14:29:53 EDT
Created attachment 91452 [details]
Screenshot of said lines

I was able to get ahold of a digital camera in order to document this
"perturbation."  I'm using Red Hat 9 with an NVIDIA GeForce 2 Go, with the
default nv driver.  These lines only appear on the left-hand side of the
screen, and as mentioned above they are at most 1-2cm in length.

Note: These lines do not tend to show up when a window is along the left-hand
side of the screen.  In other words, the backdrop is affected, not any objects
that overlap that area.  Their frequency appears to be random. They only appear
for a split-second before disappearing, although the average number of them is
enough to be annoying.

I have noticed a connection between the greatest density of them on the screen
and the present location of the mouse cursor (a pack of lines appears to follow
the mouse along the vertical horizon).

The screenshot is poor, and there are only a few lines shown, as this
phenomenon can go from minor to extreme within a matter of minutes.
Comment 11 Mike A. Harris 2003-05-01 14:36:34 EDT
Ok, I've looked at your screenshot, and this does indeed appear to be a video
driver bug.  I'll need you to try a few things in order to attempt to narrow
down the problem.

First thing to try, is to add the following to your Device section of
your X config file, and restart X:

Option "noaccel"

Please indicate if this makes the problem go away or not.  If it does, then
remove that option, and try using the various XaaNo.... options documented
on the XF86Config manpage one at a time.  See if you can narrow down any
one option or couple of options that make the problem go away.

Comment 12 Need Real Name 2003-05-02 08:44:43 EDT
I tried it with: Option "NoAccel" in the 'Device' section of XFre86Config.
This makes no difference at all. The problem persists.

In addition to what xenofalcon@hotmail.com said I can mention that the
problem not only 'erupts' in relation to the movements of the mouse cursor
but also when dragging a window across the screen (of course the mouse is
being used here).
Comment 13 Need Real Name 2003-05-10 17:32:00 EDT
I can additionally confirm that no change occurs when using NoAccel in the
XF86Config file; I even checked to see that X was parsing it.  Just for laughs,
I tried all of the specific XaaNo options together, but that made no difference
either.

It seems that the lines can in fact appear on windows along the left-hand side
of the monitor, but their color is black then and they are not as frequent,
which makes it harder to notice them.
Comment 14 Mark Lucia 2003-07-15 12:21:13 EDT
I can verify the problem, and that it nearly goes away at 24bits
Comment 15 Mike A. Harris 2003-07-15 12:32:12 EDT
This sounds like the video res/refresh being used at the current depth is
exceeding the bandwidth available perhaps.

Try lowering the refresh rate to 60Hz (you can obtain information on how to do
this via the xfree86@xfree86.org mailing list if need be), just to see if the
problem goes away. If it does, increase the refresh to 70, 72, 75, etc. until
the problem returns.

Does this change anything?
Comment 16 Mike A. Harris 2004-09-24 15:04:16 EDT
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.