Bug 834994 - rhnsd runs as initrc_t
rhnsd runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330 846002
  Show dependency treegraph
 
Reported: 2012-06-25 04:10 EDT by Milos Malik
Modified: 2013-02-21 03:36 EST (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-156.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 846002 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:36:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
basic policy for rhnsd (1.66 KB, application/x-tbz)
2012-06-25 07:26 EDT, Milos Malik
no flags Details

  None (edit)
Description Milos Malik 2012-06-25 04:10:47 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.7.19-155.el6_3.noarch
selinux-policy-doc-3.7.19-155.el6_3.noarch
selinux-policy-minimum-3.7.19-155.el6_3.noarch
selinux-policy-mls-3.7.19-155.el6_3.noarch
selinux-policy-3.7.19-155.el6_3.noarch

How reproducible:
always

Steps to Reproduce:
# yum -y install rhnsd
# run_init service rhnsd restart
# ps -efZ | grep rhnsd
  
Actual results:
system_u:system_r:initrc_t:s0   root     28048     1  0 03:36 ?        00:00:00 rhnsd

Expected results:
* rhnsd runs in its own SELinux domain
Comment 2 Milos Malik 2012-06-25 07:26:38 EDT
Created attachment 594162 [details]
basic policy for rhnsd
Comment 3 Milos Malik 2012-06-25 07:28:55 EDT
No AVCs appeared even if I used start, stop, restart actions.
Comment 4 Miroslav Grepl 2012-06-25 08:12:29 EDT
Could we treat it with rhsmcertd policy?

# chcon -t rhsmcertd_exec_t `which rhnsd`
Comment 5 RHEL Product and Program Management 2012-07-10 04:18:58 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:57:05 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Milos Malik 2012-07-17 07:40:24 EDT
(In reply to comment #4)
> Could we treat it with rhsmcertd policy?
> 
> # chcon -t rhsmcertd_exec_t `which rhnsd`

It seems so. I see no AVCs after "service rhnsd restart".
Comment 8 Milos Malik 2012-07-17 07:42:56 EDT
... and the daemon runs as rhsmcertd_t in enforcing mode.
Comment 9 Miroslav Grepl 2012-07-17 08:09:28 EDT
Great.
Comment 10 Šimon Lukašík 2012-09-19 12:08:03 EDT
(In reply to comment #8)
> ... and the daemon runs as rhsmcertd_t in enforcing mode.

Users tend to not care about running. They care about serving.
Comment 13 errata-xmlrpc 2013-02-21 03:36:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.