Bug 835012 - do not send IPv6 DNS queries when IPv6 is disabled on the host
Summary: do not send IPv6 DNS queries when IPv6 is disabled on the host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap
Version: 6.4
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Vcelak
QA Contact: David Spurek
URL:
Whiteboard:
Depends On: 812772
Blocks: 835013
TreeView+ depends on / blocked
 
Reported: 2012-06-25 08:46 UTC by Jan Vcelak
Modified: 2015-03-02 05:26 UTC (History)
7 users (show)

Fixed In Version: openldap-2.4.23-29.el6
Doc Type: Bug Fix
Doc Text:
Please, use documentation from 5.8.z erratum: http://rhn.redhat.com/errata/RHBA-2012-1071.html
Clone Of: 812772
Environment:
Last Closed: 2013-02-21 09:46:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0364 normal SHIPPED_LIVE openldap bug fix and enhancement update 2013-02-20 20:52:54 UTC

Description Jan Vcelak 2012-06-25 08:46:20 UTC
The same problem in RHEL-6

+++ This bug was initially created as a clone of Bug #812772 +++

Description of problem:
Openldap always send IPV6 queries when contacting the DNS 
even when IPV6 is completely disabled on the host.
This is causing excessive traffic.


Version-Release number of selected component (if applicable):
All the openldap versions.

How reproducible:
Always

Steps to Reproduce:
1. Install openldap.
2. Disable completely the IPV6 protocol on the host.
2. Do a LDAP query using a FQDN name as server.
  
Actual results:
The openldap is sending IPV6 queries before to use IPV4 addresses:

Expected results:
If IPV6 is disabled, then Openldap should query only IPV4 addresses.


Additional info:

...

Comment 4 Jan Vcelak 2012-09-25 16:10:29 UTC
Resolved in: openldap-2.4.23-29.el6

Comment 8 errata-xmlrpc 2013-02-21 09:46:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0364.html


Note You need to log in before you can comment on or make changes to this bug.