Bug 835059 - Memory leak in gNfs causing performance degradation
Memory leak in gNfs causing performance degradation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.2.6
All All
high Severity high
: ---
: ---
Assigned To: Vivek Agarwal
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 07:39 EDT by Rajesh
Modified: 2016-02-17 19:03 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:22:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Valgrind log obtained by running dbench for just 864 seconds(1/100th) of a day (149.31 KB, text/x-log)
2012-06-25 07:39 EDT, Rajesh
no flags Details

  None (edit)
Description Rajesh 2012-06-25 07:39:20 EDT
Created attachment 594166 [details]
Valgrind log obtained by running dbench for just 864 seconds(1/100th) of a day

Description of problem:
Several GlusterFS users report ravenous memory consumption by Gluster Nfs in 3.2.x versions over days of operation under heavy load, (possibly) causing performance degradation. 

Version-Release number of selected component (if applicable):
3.2.x, possible 3.3.x and mainline

How reproducible: always

Steps to Reproduce:
1. run dbench/<insert heavy load ops here> on an nfs mount
  
Actual results:
GNFS leaks a lot a memory and this could be the reason for performance degradation (not 100% sure).


Additional info:
Attached valgrind log.
Comment 1 Vijay Bellur 2012-07-12 21:06:06 EDT
CHANGE: http://review.gluster.com/3641 (nfs: memory leak fixes) merged in release-3.2 by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.