Bug 835060 - zeitgeist-daemon.vala:473: Unable to upgrade from schema version 1
zeitgeist-daemon.vala:473: Unable to upgrade from schema version 1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: zeitgeist (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 07:44 EDT by Kamil Páral
Modified: 2012-12-20 11:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:11:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-06-25 07:44:25 EDT
Description of problem:
I can't run zeitgeist-daemon and therefore some Gnome 3 functionality is lost. The daemon ends with non-zero return code and the following message:
$ /usr/bin/zeitgeist-daemon
[11:30:17.922141 WARNING] zeitgeist-daemon.vala:473: Unable to upgrade from schema version 1

There is a similar bug report here:
https://bugs.launchpad.net/ubuntu/+source/zeitgeist/+bug/986191

Pruning ~/.local/share/zeitgeist/ solved the problem, but that's not sufficient, it must work out of the box.

My Fedora 17 is a clean installation, but my /home is re-used from my old system. That might be the reason why the database is in the old format.

Version-Release number of selected component (if applicable):
zeitgeist-0.9.0-1.fc17.x86_64

How reproducible:
always

Expected results:
Either zeitgeist must keep the database upgrade code forever (i.e. it is always able to upgrade from schema version 1 -> schema version XYZ), or it must remove the old database a create a new one.
Comment 1 Fedora Update System 2012-09-24 19:05:25 EDT
zeitgeist-datahub-0.9.5-1.fc17,zeitgeist-0.9.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/zeitgeist-datahub-0.9.5-1.fc17,zeitgeist-0.9.5-1.fc17
Comment 2 Fedora Update System 2012-09-26 05:04:30 EDT
Package zeitgeist-datahub-0.9.5-1.fc17, zeitgeist-0.9.5-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zeitgeist-datahub-0.9.5-1.fc17 zeitgeist-0.9.5-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14788/zeitgeist-datahub-0.9.5-1.fc17,zeitgeist-0.9.5-1.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-12-20 11:11:26 EST
zeitgeist-datahub-0.9.5-1.fc17, zeitgeist-0.9.5-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.