Bug 835152 - katello-configure: Permission denied - /usr/share/katello/log/production_sql.log
katello-configure: Permission denied - /usr/share/katello/log/production_sql...
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Katello QA List
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 13:01 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Rhel6.2
Last Closed: 2012-10-24 10:13:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install log (5.11 KB, text/x-log)
2012-06-25 13:01 EDT, Jeff Weiss
no flags Details
all logs zipped (13.70 KB, application/x-gzip)
2012-06-26 08:12 EDT, Jeff Weiss
no flags Details

  None (edit)
Description Jeff Weiss 2012-06-25 13:01:09 EDT
Created attachment 594238 [details]
install log

Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.318-1.el6cf.noarch

How reproducible:


Steps to Reproduce:
1. katello-configure --deployment=cfse
2.
3.
  
Actual results:
see attachment


Expected results:
successful install

Additional info:
It sounds as though this error happens intermittently - makes me suspect it is another race condition perhaps?
Comment 1 Lukas Zapletal 2012-06-26 05:42:16 EDT
Jeff I always need full katello-debug output. At least main.log to see the puppet ordering. Hard to reproduce, it works just fine on my RHEL 6.2. I already saw this.

Can you give me output of 

ls /var/log/katello/ -la

I guess there are some files with root:root owner. The thing is according to our script, there is nothing creating them.
Comment 2 Jeff Weiss 2012-06-26 08:12:09 EDT
Created attachment 594457 [details]
all logs zipped
Comment 3 Jeff Weiss 2012-06-26 08:12:47 EDT
/scpc:root@katello-ci-rhel6.usersys.redhat.com:/var/log/katello/katello-configure $ ls -al
total 138
drwxr-x---   2 katello        katello    4096 2012-06-25 11:25 .
drwxr-x---   3 katello        katello    4096 2012-06-25 11:24 ..
-rw-r--r--   1 root           root        130 2012-06-25 11:24 cpsetup.log
-rw-r--r--   1 root           root         12 2012-06-25 11:23 create-postgresql-candlepin-user.log
-rw-r--r--   1 root           root         16 2012-06-25 11:24 create-postgresql-katello-database.log
-rw-r--r--   1 root           root         12 2012-06-25 11:24 create-postgresql-katello-user.log
-rw-r--r--   1 katello        katello    2194 2012-06-25 11:25 db_env.log
-rw-r--r--   1 katello        katello    5235 2012-06-25 11:25 db_migrate.log
-rw-r-----   1 katello        katello      37 2012-06-25 11:23 katello-configure.conf
-rw-r-----   1 katello        katello  124972 2012-06-25 11:25 main.log
/scpc:root@katello-ci-rhel6.usersys.redhat.com:/var/log/katello/katello-configure $
Comment 4 Lukas Zapletal 2012-06-26 09:49:37 EDT
Ok, this precreates log files created by Rails in advance with correct owner and permissions. It prevents all errors like those. We are mangling with log directory permissions, I am going to remove this in the upstream later on this week. But this fixes the bug.

https://github.com/Katello/katello/pull/243
Comment 6 Ivan Necas 2012-06-27 06:14:18 EDT
Merged in commits:

commit 3c2d40a80add6ef77c6d13f8d0c4de4afa9fedf1
Author: Lukas Zapletal <lzap+git@redhat.com>
Date:   Wed Jun 27 11:50:27 2012 +0200

    835152 - logs in advanced during installation fix

commit 847d017efa5b925df3a4d2a3b452f7e13710da9f
Author: Lukas Zapletal <lzap+git@redhat.com>
Date:   Tue Jun 26 15:38:46 2012 +0200

    835152 - creating logs in advanced during installation
Comment 7 Mike McCune 2012-10-24 10:13:02 EDT
closing, upstream since this has been in for quite a while

Note You need to log in before you can comment on or make changes to this bug.