This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 835153 - pppd unrecognized option 'wwan0' when try to connect to mobile broadband using 3G USB dongle
pppd unrecognized option 'wwan0' when try to connect to mobile broadband usi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 834871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 13:01 EDT by Deian
Modified: 2013-01-27 20:47 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 14:16:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages file since boot (22.18 KB, application/x-gzip)
2012-06-26 16:23 EDT, Deian
no flags Details

  None (edit)
Description Deian 2012-06-25 13:01:42 EDT
Description of problem:

When NetworkManager tries to establish ppp connection using 3G USB dongle it is unable to do so.

Version-Release number of selected component (if applicable):

ppp-2.4.5-22.fc17.i686
NetworkManager-0.9.4.0-9.git20120521.fc17.i686

How reproducible:

1. Create mobile broadband connection
2. Try to connect

  
Actual results:

Jun 25 19:47:59 len-netbook NetworkManager[478]: <info> pppd started with pid 1201
Jun 25 19:47:59 len-netbook pppd[1201]: unrecognized option 'wwan0'
Jun 25 19:47:59 len-netbook NetworkManager[478]: <warn> pppd pid 1201 exited with error: pppd options error



Expected results:


expected to connect


Additional info:

I have never had issues with this USB dongle before fedora 17
Comment 1 Michal Sekletar 2012-06-26 06:10:51 EDT
I've made only minor fixes on ppp side recently, so I guess this issue is more related to NetworkManager and its use of pppd.
I've contacted NM team and someone will take a look at this, but in the meantime can you provide content of your /etc/ppp/options and ~/.ppprc files? Thank you.
Comment 2 Jirka Klimes 2012-06-26 07:15:01 EDT
Would you attach /var/log/messages file? Also, grab pppd command line so that we can see cmd arguments: "ps aux | grep pppd".

You can run e.g.
$ while true; do ps aux | grep pppd; sleep 0.5; done
in a terminal and then activate a 3G connection via NetworkManager.

What modem do you use, what is output of
$ lsusb
Comment 3 Deian 2012-06-26 16:23:07 EDT
Created attachment 594592 [details]
/var/log/messages file since boot
Comment 4 Deian 2012-06-26 16:23:54 EDT
Would you attach /var/log/messages file? 

==> /var/log/messages file attached. 

Also, grab pppd command line so that we can see cmd arguments: "ps aux | grep pppd".

===> The command line is:
root      4421  0.0  0.0   1404   180 ?        D    23:16   0:00 /usr/sbin/pppd nodetach lock nodefaultroute user mtel wwan0 noipdefault noauth usepeerdns lcp-echo-failure 0 lcp-echo-interval 0 ipparam /org/freedesktop/NetworkManager/PPP/0 plugin /usr/lib/pppd/2.4.5/nm-pppd-plugin.so



What modem do you use, what is output of
$ lsusb


Bus 002 Device 005: ID 19d2:0063 ONDA Communication S.p.A. ZTE K3565-Z HSDPA

Thank you,

Regards, 
Deyan
Comment 5 Michal Sekletar 2012-06-27 03:52:13 EDT
Based on log I assume that proper ttyname option, which should appear in pppd command-line, is ttyUSB3. I can't tell why NM uses wwan0 instead, thus changing component to NM. If anyone thinks otherwise, feel free to change it back to ppp.
Comment 6 Deian 2012-06-27 04:47:11 EDT
When I plug the dongle in, I get new interface created which is called wwan0. I guess it has something to do with this.

[deian@kamaz ~]$ ip li show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether 00:1e:37:23:de:6a brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT qlen 1000
    link/ether 00:1f:3b:26:d2:c1 brd ff:ff:ff:ff:ff:ff
5: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT qlen 100
    link/none 
6: wwan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether a6:b4:4c:b1:1a:94 brd ff:ff:ff:ff:ff:ff
Comment 7 Deian 2012-07-03 08:24:28 EDT
Hello,

Since I need the USB dongle, can you recommend a workaround until a fix is available ?
Comment 8 Michal Sekletar 2012-07-03 08:55:22 EDT
You can give wvdial a try and use it instead of NM.
Comment 9 Jirka Klimes 2012-07-03 11:28:25 EDT
The wwan0 interface is pseudo-network interface created by a new 'qmi_wwan' kernel driver http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob;f=drivers/net/usb/qmi_wwan.c;h=3767a122586043512cd6ded88b562fd9b97df88f;hb=HEAD

So, as another workaround I suggest you blacklist 'qmi_wwan' driver and give NM/MM another try.

# echo "blacklist qmi_wwan" > /etc/modprobe.d/blacklist-qmi_wwan.conf
Comment 11 Aleksander Morgado 2012-07-17 06:27:57 EDT
Can anyone get ModemManager debug logs by following the steps given in
section "Debugging NetworkManager 0.8 and 0.9 3G connections" of the
following page?:
https://live.gnome.org/NetworkManager/Debugging
Comment 12 Dan Williams 2012-07-17 09:41:48 EDT
Darn, I didn't realize we'd be hit by this so soon.  I guess we should probably ignore eth interfaces that are driven by qmi_wwan in ModemManager until we actually have QMI support, which means that for 0.5 and 0.6 we probably just ignore them forever.
Comment 13 Dan Williams 2012-07-17 10:31:51 EDT
Fixed upstream as:

commit d09375e08e4234ae87c5a1af5e5cbcdc84771742
Author: Dan Williams <dcbw@redhat.com>
Date:   Tue Jul 17 09:07:40 2012 -0500

    core: ignore unsupported qmi_wwan ports (rh #835153)

(for 0.6, also cherry-picked to 0.5)
Comment 14 Josh Boyer 2012-07-20 09:09:03 EDT
*** Bug 834871 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2012-07-20 16:12:36 EDT
ModemManager-0.5.3.96-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ModemManager-0.5.3.96-1.fc17
Comment 16 Fedora Update System 2012-07-20 19:47:09 EDT
ModemManager-0.5.3.96-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ModemManager-0.5.3.96-1.fc16
Comment 17 Fedora Update System 2012-07-20 22:49:23 EDT
Package ModemManager-0.5.3.96-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ModemManager-0.5.3.96-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10907/ModemManager-0.5.3.96-1.fc17
then log in and leave karma (feedback).
Comment 18 klaus scholl 2012-07-28 00:16:47 EDT
The update "ModemManager-0.5.3.96-1.fc17" works!! I tested it with Linux kernel 3.4.5-2.
Thanks to the RedHat team for quickly solving my problem (Bug 834871).
Comment 19 Fedora Update System 2012-08-01 14:16:44 EDT
ModemManager-0.5.3.96-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-08-30 21:01:24 EDT
ModemManager-0.5.3.96-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.