Bug 835161 - Extend CRL API to regen crl on disk
Extend CRL API to regen crl on disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.1
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Chris Duryee
Hayk Hovsepyan
: Triaged, ZStream
Depends On: 821644 828313
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 13:39 EDT by James Bowes
Modified: 2014-09-18 11:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 828313
Environment:
Last Closed: 2012-10-24 10:22:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 James Bowes 2012-06-25 13:40:16 EDT
Should be easy to fix, just move the file writing code the pinsetter job uses to somewhere both the pinsetter job and the resource can get it.
Comment 2 James Bowes 2012-06-25 13:42:21 EDT
will need a 0.6 branch and build off of that.
Comment 3 Lukas Zapletal 2012-06-26 04:20:38 EDT
So are we going to change the /candlepin/crl url or you are going to implement this feature on this exact url?
Comment 4 Garik Khachikyan 2012-06-26 04:28:03 EDT
giving QE-ack here. serious issue to get fixed.
Comment 5 Chris Duryee 2012-06-27 16:23:38 EDT
Lukáš,

The URL will remain the same, I am going to just have it write to disk when called.
Comment 6 Chris Duryee 2012-06-28 12:50:47 EDT
this is fixed in 0.7

614354f15c138 master 0.7.4+

I still need to apply the patch to 0.6 branch
Comment 8 Lukas Zapletal 2012-08-03 05:00:36 EDT
QA: To test this feature, please see:

https://bugzilla.redhat.com/show_bug.cgi?id=821644
Comment 9 Hayk Hovsepyan 2012-09-05 03:53:07 EDT
Tested on revision:
katello-glue-candlepin-1.1.9-1.git.95.0ed1e6f.el6.noarch
katello-configure-1.1.7-1.el6.noarch
katello-repos-1.1.2-1.el6.noarch
qpid-cpp-client-0.14-16.el6.x86_64
qpid-cpp-server-ssl-0.14-16.el6.x86_64
pulp-common-1.1.12-1.el6.noarch 
katello-glue-pulp-1.1.9-1.git.95.0ed1e6f.el6.noarch
pulp-1.1.12-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.1.2-1.el6.noarch
qpid-cpp-server-0.14-16.el6.x86_64
qpid-cpp-client-ssl-0.14-16.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
katello-certs-tools-1.1.8-1.el6.noarch
candlepin-selinux-0.7.8.2-1.el6.noarch
katello-glue-foreman-1.1.9-1.git.95.0ed1e6f.el6.noarch
pulp-selinux-server-1.1.12-1.el6.noarch
katello-1.1.9-1.git.95.0ed1e6f.el6.noarch
candlepin-tomcat6-0.7.8.2-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-1.1.5-1.git.100.1b905cf.el6.noarch
python-qpid-0.14-8.el6.noarch
candlepin-0.7.8.2-1.el6.noarch
katello-common-1.1.9-1.git.95.0ed1e6f.el6.noarch
katello-selinux-1.1.1-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.1.5-1.git.100.1b905cf.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
mod_wsgi-3.3-3.pulp.el6.x86_64


Now "admin crl_regen" regenerates "/var/lib/candlepin/candlepin-crl.crl" file and described problems are fixed.
Comment 10 Mike McCune 2012-10-24 10:22:03 EDT
closing, currentrelease since these seemingly got missed in the 1.0.1 errata
Comment 11 Hayk Hovsepyan 2012-12-04 10:17:29 EST
Automated in method: "com.redhat.qe.katello.tests.e2e.CRLRegen.test_crl_regen()"
Comment 13 Mike McCune 2013-08-16 14:19:45 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.