Bug 835181 - No video from webcam in cheese
No video from webcam in cheese
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 14:45 EDT by Stuart D Gathman
Modified: 2012-07-24 15:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 842876 (view as bug list)
Environment:
Last Closed: 2012-07-13 09:06:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart D Gathman 2012-06-25 14:45:36 EDT
Description of problem:
no video from webcam

Version-Release number of selected component (if applicable):
cheese-3.2.2-1.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. run cheese from menu
2.
3.
  
Actual results:
black video window

Expected results:
video from webcam

Additional info:
Other webcam applications, e.g. UCView, work perfectly.
lsusb:
Bus 001 Device 003: ID 04f2:a133 Chicony Electronics Co., Ltd Gateway Webcam

Previously reported in bug#689995 for Fedora 15.
Comment 1 Stuart D Gathman 2012-06-25 14:47:38 EDT
User Accounts/Take a Photo is also broken, and apparently uses cheese-libs.
Comment 2 Hans de Goede 2012-06-25 14:57:53 EDT
A lot of work has gone into fixing various cheese bugs in F-17, any chance you can upgrade to Fedora-17 and give things a try there ?
Comment 3 Stuart D Gathman 2012-07-04 23:13:05 EDT
Planning to try it from a LiveCD - hope that's good enough.
Comment 4 Hans de Goede 2012-07-05 04:14:49 EDT
(In reply to comment #3)
> Planning to try it from a LiveCD - hope that's good enough.

Yes that is fine, please do: 
yum update 'cheese*' 'gstreamer*'
in the live environment before testing, so that you get the latest versions.
Comment 5 Stuart D Gathman 2012-07-12 20:19:54 EDT
Installed F17 in a logical volume.  Cheese works fine after updating everything.  Sorry, forgot to test *before* updating.  But in any case, problem is fixed in updated F17.
Comment 6 Hans de Goede 2012-07-23 04:03:19 EDT
Thanks for testing this with Fedora-17!
Comment 7 Stuart D Gathman 2012-07-24 15:25:14 EDT
Oops, I tested the Micromedia Webcam on F17 - which already worked on F16.  I just noticed this bug report says Chicony web cam (which worked on F14) was broken on F16 (but worked in ucview).  I just now installed F17 on this computer and updated, and not only does the Chicony web cam not work in cheese, it doesn't work in ucview either!

Note You need to log in before you can comment on or make changes to this bug.