Bug 835209 - ovirt-engine-backend: some tasks related events are not translated properly [TEXT]
ovirt-engine-backend: some tasks related events are not translated properly [...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Oved Ourfali
Tomas Dosek
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 15:23 EDT by Oded Ramraz
Modified: 2016-02-10 14:03 EST (History)
9 users (show)

See Also:
Fixed In Version: si11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-06-25 15:23:06 EDT
Description of problem:

Some tasks related events are not translated properly , e.g when attaching tag to VM i see the following message under tasks: "AttachVmsToTag" ( why is it task BTW? )



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Itamar Heim 2012-06-26 05:27:03 EDT
also when adding a disk:
"Adding Disk DiskName"
Comment 2 Oded Ramraz 2012-06-26 11:09:59 EDT
"Failed to restart VM 33-4 on Host VdsName"
Comment 3 Oded Ramraz 2012-06-28 16:36:58 EDT
"Add-Disk operation of 'dd' was initiated on VM VmName by vdcadmin."
Comment 4 Oved Ourfali 2012-07-08 07:33:33 EDT
I took a look, and there are many tag/bookmark operations that are monitored (i.e. appear in the tasks tab).

Should I remove them all? Don't seem to be very relevant to be monitored as tasks.
Comment 5 Oved Ourfali 2012-07-08 08:18:14 EDT
Need info regarding the messages as well (in addition to my previous comment on monitoring the task).

1. "Failed to restart VM 33-4 on Host VdsName"
2. "Add-Disk operation of 'dd' was initiated on VM VmName by vdcadmin."

Message #1 can be caused due to the host being null in the code, and that might happen if it wasn't set at all. Can we remove the VdsName from this message?
If not, we need to switch to two message, one when the host is null, and one when it isn't. A log can help here to see how you got to this situation.

Message #2 - it is simple. We use the same code when adding a disk to a VM, and when adding it independently. In the former the log is correct, however in the latter no VM is involved, so the VM is null. Should we split it to two different messages, or using the message "Add-Disk operation of 'dd' was initiated by vdcadmin" enough?
Comment 6 Miki Kenneth 2012-07-09 05:52:10 EDT
Message 1:
this is a corner case - it is suffiecent to change the VdsName to <null>.

Message 2:
Split is required. The VmName is important for the Advance View of the Events TAB.
It is used for auditing mechanism.
Comment 10 Tomas Dosek 2012-07-31 04:52:50 EDT
Verified - si12 - All message types mentioned above are properly translated.

Note You need to log in before you can comment on or make changes to this bug.