Bug 835274 - ovirt-engine-webadmin-portal: edit cluster policy options values are not alligned
ovirt-engine-webadmin-portal: edit cluster policy options values are not alli...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Gilad Chaplik
Oded Ramraz
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 16:27 EDT by Oded Ramraz
Modified: 2016-02-10 14:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 10:43:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (23.03 KB, application/zip)
2012-06-25 16:27 EDT, Oded Ramraz
no flags Details
screen shot (13.13 KB, application/zip)
2012-06-26 04:09 EDT, Oded Ramraz
no flags Details

  None (edit)
Description Oded Ramraz 2012-06-25 16:27:10 EDT
Description of problem:

Edit cluster policy option values are not alligned : some text is under the check box , some near to it , and some has centralization problem ( see attached image )
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Oded Ramraz 2012-06-25 16:27:56 EDT
Created attachment 594276 [details]
screen shot
Comment 2 Itamar Heim 2012-06-26 04:05:03 EDT
oded - the attachment is incorrect, please add correct attachment.
thanks
Comment 3 Oded Ramraz 2012-06-26 04:09:24 EDT
Created attachment 594392 [details]
screen shot
Comment 4 Gilad Chaplik 2012-06-26 04:13:16 EDT
Oded, which browser is it, and what is the screen resolution?
Comment 5 Gilad Chaplik 2012-06-26 05:03:41 EDT
It seems that in zooming in/out, check boxes and radio buttons, are not getting zoomed, and this causes positioning problem in the view (i.e. when zooming out, the checkbox stays 100% while other components are smaller, this causes the view not to be align).

this is a known issue across web applications, zooming is a browser-specific feature, I don't think we need to guarantee that application is perfect even when you zoom.

I suggest to close the bug.

Vojtech, do you have other comments?
Comment 6 vszocs 2012-06-27 08:08:53 EDT
I agree with Gilad.

Even though native check-box and radio-button widgets can be styled to some extent, the browser ultimately takes care of rendering them on the screen. Each browser typically renders its check-box and radio-button widgets differently.

When zooming in/out, native check-box and radio-button appearance depends on browser engine implementation. I think that most browsers don't support scaling native widgets proportionally, according to zoom value.

The only workaround for this problem is to be fully in charge of check-box and radio-button rendering. This would mean we would need to develop custom check-box and radio-button widgets, using standard HTML/CSS. I don't think this is worth the effort.

Since the zoom feature is browser-specific, we cannot guarantee that application UI won't get broken when user changes the zoom value. This is similar to other browser-specific features, like changing default font size (CSS override). The user simply has to be aware that any browser-specific features might break UI.

Note You need to log in before you can comment on or make changes to this bug.