Bug 835298 - Attempt to extract DNS server addresses from NetWorkManager fails
Attempt to extract DNS server addresses from NetWorkManager fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnssec-trigger (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 17:39 EDT by Tom Hughes
Modified: 2012-07-11 19:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 19:50:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2012-06-25 17:39:02 EDT
Description of problem:

The NetworkManager dispatcher script which dnssec-trigger installs fails because it asks nmcli for non-existent attributes.

Version-Release number of selected component (if applicable):

dnssec-trigger-0.10-4.fc17.x86_64

How reproducible:

Run /etc/NetworkManager/dispatcher.d/01-dnssec-trigger-hook and then check the dnssec-trigger status and see that no servers have been found.

Additional info:

The problem is that the script asks for IP4-DNS and IP6-DNS which are properties that don't seem to exist.

This version of the command seems to work:

ips="`$nmcli -f IP4,IP6 dev list | fgrep 'DNS' | awk '{print $2;}'`"
Comment 1 Fedora Update System 2012-06-28 11:12:07 EDT
dnssec-trigger-0.11-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dnssec-trigger-0.11-3.fc17
Comment 2 Fedora Update System 2012-06-29 13:47:19 EDT
dnssec-trigger-0.11-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dnssec-trigger-0.11-1.fc16
Comment 3 Fedora Update System 2012-06-30 17:49:26 EDT
Package dnssec-trigger-0.11-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnssec-trigger-0.11-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10069/dnssec-trigger-0.11-3.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-07-11 19:50:40 EDT
dnssec-trigger-0.11-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2012-07-11 19:58:37 EDT
dnssec-trigger-0.11-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.