Bug 835305 - Fedora 17 gnu emacs 24.0.97 rmail can no longer read mail spool files
Fedora 17 gnu emacs 24.0.97 rmail can no longer read mail spool files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Klíč
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 18:29 EDT by William Bader
Modified: 2013-03-03 18:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 10:04:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An old RMAIL file from Fedora 8 (183 bytes, text/plain)
2012-06-25 21:12 EDT, William Bader
no flags Details

  None (edit)
Description William Bader 2012-06-25 18:29:00 EDT
Description of problem:

Run emacs
Use "M-X rmail" to run rmail.
It says that you have no mail even if there is mail in your /var/spool/mail/ file.
If you force the spool file, for example with the line below in $HOME/.emacs
(setq rmail-primary-inbox-list "/var/spool/mail/william")
then rmail gives the error "Invalid mbox file¨.
I can read my mail with other applications, so the problem is emacs-rmail and not the file format.
I get mail with a cron job that runs fetchmail, and then I think that fetchmail forwards the mail to sendmail which writes it into the mail spool file.

Version-Release number of selected component (if applicable):

sony ~$ rpm -qa | grep '^emacs'
emacs-common-24.0.97-1.fc17.x86_64
emacs-filesystem-24.0.97-1.fc17.x86_64
emacs-24.0.97-1.fc17.x86_64
sony ~$ rpm -qa | grep '^fetchmail'
fetchmail-6.3.21-2.fc17.x86_64
sony ~$ rpm -qa | grep '^sendmail'
sendmail-cf-8.14.5-12.fc17.noarch
sendmail-8.14.5-12.fc17.x86_64
sony ~$ uname -a
Linux sony 3.4.3-1.fc17.x86_64 #1 SMP Mon Jun 18 19:53:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Happens every time.

Steps to Reproduce:
1. Send your self mail.
2. Wait for the mail to arrive in your var spool mail file.
3. Run emacs and start rmail with M-X rmail.
  
Actual results:

It says that your mail file has no messages.

Expected results:

It should show the messages.

Additional info:

I looked on google and didn't see anything specific to this problem, but I did see a related issue where emacs can corrupt files if you configure it to ensure that files end with a newline.  I have not set that option.
Comment 1 William Bader 2012-06-25 21:09:33 EDT
I found the problem.
According to NEWS.23, rmail no longer converts messages to Babyl format.
When I upgraded from Fedora 8 to Fedora 17, I restored my user account and everything inside it including the Fedora 8 $HOME/RMAIL in Babyl format.
Rmail in emacs 24 couldn't handle the old Babyl format RMAIL.
I fixed the problem by removing RMAIL and RMAIL~ (I save my mail to text files, so my RMAIL is usually empty except for the current batch of incoming mail.)
Comment 2 William Bader 2012-06-25 21:12:39 EDT
Created attachment 594324 [details]
An old RMAIL file from Fedora 8
Comment 3 Karel Klíč 2012-07-11 10:04:14 EDT
Ok, thank you for the clarification.

I checked that rmail in emacs-24.1-1.fc17.x86_64 can read /var/spool/mail files created in recent Fedora.

Note You need to log in before you can comment on or make changes to this bug.