Bug 835318 - bbdb fails to add new e-mail addresses because emacs-24 changes run-hook-with-args return value
bbdb fails to add new e-mail addresses because emacs-24 changes run-hook-with...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs-bbdb (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Göran Uddeborg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 20:40 EDT by John Heidemann
Modified: 2012-07-19 05:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 05:18:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix run-hook-with-args API change in emacs-24 triggered by bbdb (657 bytes, patch)
2012-06-25 20:43 EDT, John Heidemann
no flags Details | Diff

  None (edit)
Description John Heidemann 2012-06-25 20:40:46 EDT
Description of problem:
bug: 
bbdb.el's
(defun bbdb-canonicalize-address (net)

calls
run-hook-with-args

but as of 24.0.50 that no longer returns a value:

https://groups.google.com/forum/?fromgroups#!topic/gnu.emacs.bug/jD2BIBSWG8U

as a result, bbdb no longer records new e-mail addresses :-(


Version-Release number of selected component (if applicable):
emacs-bbdb-2.35-7.fc17.noarch
and
emacs-24.0.97-1.fc17.x86_64

How reproducible:


Steps to Reproduce:
1.Run emacs and browse a new message (a message that bbdb has never seen)
in your mail reader that uses bbdb.
(For me, mh-e.)
2. Execute something that should discover the e-mail address in the current message,
like M-x bbdb/mh-pop-up-bbdb-buffer
3. be sad when the buffer shows a name, but no bbdb-snarf'ed e-mail address
  
Actual results:
new bbdb record created with a name, but no net: field

Expected results:
a new bbdb record with both a name and an e-mail address grabbed from the message

Additional info:

https://groups.google.com/forum/?fromgroups#!topic/gnu.emacs.bug/jD2BIBSWG8U
discusses the problem and identifies emacs-24's helpfully documented change in the run-hook-with-args command

I have a fix that I will post in a followup.
Comment 1 John Heidemann 2012-06-25 20:43:25 EDT
Created attachment 594317 [details]
patch to fix run-hook-with-args API change in emacs-24 triggered by bbdb
Comment 2 Göran Uddeborg 2012-07-04 17:51:47 EDT
Thanks for your report.  I'll try to take care of this; I am a new co-maintainer of the emacs-bbdb package.

Since you have investigated the issue, have you also checked if the upstreams are aware already?  Or should we point it out them (him)?
Comment 3 John Heidemann 2012-07-04 20:22:09 EDT
I attempted to post the bug to the bbdb-info mailing list, but my post was held for moderator approval (even after I joined the list).  If you know a better way to upstream the bug, please advise.
Comment 4 Göran Uddeborg 2012-07-05 11:37:13 EDT
I have no special contacts with upstreams, but I did manage to send a message to the bbdb-info mailing list after subscribing.  I don't know why it worked for me but not for you, but there is a short report there now.

Your patch didn't quite apply, so I had to adjust it somewhat.  I hope I got it right, but please do test the update I'll push shortly.  I don't normally use bbdb, so the testing I can do myself is a bit rudimentary, to put it mildly.
Comment 5 Fedora Update System 2012-07-05 11:57:08 EDT
emacs-bbdb-2.35-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/emacs-bbdb-2.35-8.fc17
Comment 6 John Heidemann 2012-07-05 15:55:22 EDT
Thanks, can you post the updated patch (mentioned in comment #4) so I can try it in parallel with the new package coming down the line?
Comment 7 Göran Uddeborg 2012-07-05 16:20:58 EDT
I guess the best testing is if you pick up the packages directly via https://admin.fedoraproject.org/updates/emacs-bbdb-2.35-8.fc17
Comment 8 John Heidemann 2012-07-05 17:45:40 EDT
Yes, I went there. It's Much Less Than Obvious which of the several links gets me to the patch, or even the source or binary of the package itself.  (I think I've now found the src.rpm, but whew...a maze of twistly URLs, all alike.)
Comment 9 Fedora Update System 2012-07-05 19:38:22 EDT
Package emacs-bbdb-2.35-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-bbdb-2.35-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10282/emacs-bbdb-2.35-8.fc17
then log in and leave karma (feedback).
Comment 10 Göran Uddeborg 2012-07-07 03:50:41 EDT
> It's Much Less Than Obvious which of the several links gets me to the patch

Um, right.  I could have put in more direct URL:s I guess.  I'll try to think about that next time.  (This package is available in testing now, so for this time it doesn't matter any more.)
Comment 11 Fedora Update System 2012-07-19 05:18:49 EDT
emacs-bbdb-2.35-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.